Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm a bit of a newbie, so I'm just going to throw as much information as I can at you and hope that it's all relevant. Not sure if important, but my computer has had Ubuntu since 8.04 (I just kept upgrading)

So back in fall 2012 I bought a Nvidia gtx 560 video card that doesn't have optimus technology, and I popped into my PCI-e 16x slot and it pretty much worked from the get go. It was almost effortless how easily my computer (Ubuntu 12.04) switched from its internal onboard ATI chipset to the newer GPU. I still had issues running the new XCOM game, but Minecraft played with ease, it wasn't until 12.10 that the XCOM game (with wine 1.5) that it started working, and I enjoyed myself thoroughly. However the problem started when I decided to plunge head-first into upgrading the second 13.04 was released (I forced the upgrade). All these issues came up that prevented me from operating my computer properly. So I reformatted back to 12.04, since then (it's been a couple of months now.), my video card can't be detected (I've tried to disable display port and switch to GFX0 in BIOS), but I can't seem to find the right driver for it either (I've tried nvidia_current, 304, and 310); everytime I've installed a driver and rebooted, I switch the display cable over to the video card, and my monitor immediately goes to sleep, when I switch it back to the onboard, it runs like normal. I've remove and reinserted the card countless times, cleaned the slot and the rest of the motherboard of dust, I've done research into other posts online but to no avail. I'm just about ready to become a crazy cat-person that swears off all technology if I can't make this work. Can anyone help me?

P.S.- I'm deluding myself into thinking the card is still operational because I can both hear and feel the fan running when the computer's on and the card plugged in to the PSU. Also, when I removed it before, I noticed the 4 to 6 pin connector cables (4-pin is one row, and the 6-pin are two rows of three) it uses are somewhat loose (I can almost pull one of the pins completely out on the 6 side). I tightened that up as best I could but I still keep getting "No signal, monitor going to sleep"

share|improve this question
    
Ok, few clarifying questions. Did you buy is as new and does it have a warranty? Have you tried removing the card from PCI-E slot and then putting it back? Can you test it in another computer that has Windows installed? Is the problem with the power connection related to the cable that comes from the power supply or is there something wrong with the cards power sockets? –  Tanel Mae Jul 20 '13 at 7:14
    
I bought it new off of newegg.com. Yes, I have tried removing it. I even removed it, ran the computer for a bit, and then put it back in and plugged the monitor to it, but to no avail. At the moment, I can't test it on a windows computer, I'd have to wait a couple days on that. The PSU cable is the possible issue, I can almost pull the wire out of the connector (specifically, the brown couple-wire that's in the center. Not sure if that helps). And considering there are no signs of melting or scorching, I think the power is fine, just the fact that maybe that specific plug wasn't getting power. –  L0stTh0ught Jul 20 '13 at 13:12
    
Make sure that the card works. If it doesn't and you still have warranty then just return it to the shop. If possible, also test your PSU. If the card is ok the issue might be either with Ubuntu or your PSU cabling. When it comes to the PSU you are likely to get better help from forums that are about PC hardware or about PCs in general. But iff it turns out to be Ubuntu related only, then start a new question here. Make it then shorter and precise, give all the evidence you have collected. Then you are more likely to get help. Good luck with testing your card and PSU. Be strong! –  Tanel Mae Jul 21 '13 at 7:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.