Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a problem with gedit. If I start writing a new file or edit an existing file the Save button and short cut to save is disabled. If I exit a modified document a dialog opens with the following text:

Changes to the document "<Name>" will be permanently lost. Saving has
been disabled by the system administrator.

The interesting part about this is that I can save the file from right clicking the document in the side panel.

I have tried removing gedit-related gconf from the terminal while logged out (rm -rf .gconf/apps/gedit-2/), but it doesn't work.

share|improve this question
1  
What is the path to the directory you are working on? Have you done something similar to this thread? Also, read this thread. –  edwin Jul 19 '13 at 23:41
    
That's it. In Ubuntu-tweak there is a checkbox that disables Saving to disk. I though that was disabling hibernation and checked it. It might be a duplicate since other Gnome applications might behave the same. –  Sylwester Jul 19 '13 at 23:49
    
If you wish you can add this as the answer and accept it, that way it can be of use to others. –  edwin Jul 19 '13 at 23:51
add comment

1 Answer 1

up vote 3 down vote accepted

It seems to be a user wide setting in Gnome that Gnome applications can see, and if they want, obey.

In Ubuntu-tweak:

  • Go to Tweaks > Michellaneous
  • Uncheck Disable save to disk

Without Ubuntu-tweak:

  • Press ALT+F2
  • Enter gsettings reset org.gnome.desktop.lockdown disable-save-to-disk
  • Press Return/Enter
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.