Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a question about starting and using postgresql once it has been installed. Here is the command that I have used and the error message:

dbacc@dbacc-Compaq-615:~$ /etc/init.d/postgresql start

chmod: changing permissions of `/var/run/postgresql': Operation not permitted

The installation seemed to go well. I must be missing something (Ubuntu rookie).

Thank you for any suggestions you can give me.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

You need to be superuser to run the software using the init.d script.

Try using sudo /etc/init.d/postgresql start to run the software.

share|improve this answer
    
Thank you Thomas, that worked! Although I am still having problems setting up the program. I have read the instructions about setting up and configuring the server and tried all of the commands, but nothing else works. Do you know of an online resource that might be better for a beginner than the Postgresql manual?? Thank you! –  David Jul 19 '13 at 23:38
    
@David Does this page from the community docs help? (click this) Also, don't forget to accept this as the answer if it helped. –  Thomas W. Jul 19 '13 at 23:44
    
Thanks again, Thomas. The info on the link looks just like what I need! How do I "accept" your answer??? Ok, now I see the button to "accept". Ubuntu members like you are an amazing help! Thank you! –  David Jul 20 '13 at 0:02
    
You're welcome! Glad I could help you out! :) –  Thomas W. Jul 20 '13 at 0:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.