Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I got a fresh Ubuntu 13.04 full os encryption installed to my SSD. On boot I'm not able to type anything at all in the decryption screen. The keyboard works perfectly fine in GRUB, but in decryption screen it's like the keyboard gets disabled. I've also tried recovery mode, not any luck there either...

I've tried to reinstall multiple times, but the same happens over and over again. However, when I install it to a hard drive, Ubuntu works perfectly fine.

I am using Ubuntu's own full os encryption, from installation.

Anyone got any tips?

As always, thanks in advance!

EDIT: I've also tried moving boot partition to a hard drive, but that doesn't help at all

share|improve this question

1 Answer 1

Before you start messing about with your partitions, you should set your SATA mode to AHCI instead of RAID (default for ssd's) in your BIOS. Also remember to remove all the partition metadata using:

sudo dmraid -E -r /dev/sda

(change sda to the appropriate name for your SSD)

These were the main issues in my case.

Also, this question might be useful for you: Installing Ubuntu 13.04 on a MSATA SSD

share|improve this answer
    
Your sugestion didn't work. SATA mode in BIOS was already set to AHCI. –  user2600769 Feb 12 at 21:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.