Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'd like to place any new emacs windows maximized vertically on the left half of the screen. The window rules plugin of Compiz aims to solve these kind of problems, but I don't see an option to do this there.

Just to restate:

I don't want do drag the window to the left until it snaps and maximizes every time I open a new window.

I want this to be done automatically on per-application basis.

share|improve this question
    
I think there is no such option yet. –  January Jul 19 '13 at 7:53

1 Answer 1

Combine "Window Rules" plugin with "Place Windows" plugin. First one (tab "Size rules") will set the desired size, the second one (tab "Fixed Window Placement") will set the desired position of the windows with title=^emacs.

share|improve this answer
    
I tried that one as well. It doesn't offer to maximize a window vertically. –  user1350992 Jul 19 '13 at 14:17
    
Right you are. "Place Windows" cannot resize windows. But "Window Rules" can. Just calculate the desired window size and set it there. I've updated my answer. –  whtyger Jul 19 '13 at 14:32
    
Let me state this again: I'm interested /only/ in maximize vertically option. I've tried what you described and it doesn't work. It makes the window either too small or too big, never the full desktop height. –  user1350992 Jul 19 '13 at 14:34
    
The closest thing in ccsm to what I want is the Grid plugin. Its "Put Left" function is exactly what I need. But I don't want to use the shortcut each time. I want it automatic. –  user1350992 Jul 19 '13 at 14:36
    
I've tested everything once again. Well, my advice works correctly for graphical windows. emacs is a bit specific. If you turn on "Resize Info" plugin, you'll see, that emacs shows symbols count on resize, not pixels. Workaround: with turned on "Resize Info" plugin open some graphical (i.e. non terminal) window, for example gedit, resize it as you wish your emacs window must be and get its pixel size. Then set this size in "Window Rules" plugin for your emacs window. I got it working as desired. –  whtyger Jul 19 '13 at 15:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.