Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was following the steps given on this page to build Unity 8. When i run the command ./build -s, it works fine, adds the PPAs required and then it runs the apt-get command, and therein lies the error. I get the following error-

Failed to fetch http://ppa.launchpad.net/phablet-team/desktop-deps/ubuntu/dists/precise/main/source/Sources 404 Not Found

and

Failed to fetch http://ppa.launchpad.net/phablet-team/desktop-deps/ubuntu/dists/precise/main/binary-i386/Packages 404 Not Found

And so the, ./build -s command is not executed properly, how can this be solved? My system is on Ubuntu 12.04

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

The first step of the instructions you're following says "First make sure you’re desktop working environment is at least 13.10 / saucy".

The PPA that you are trying to add currently only contains packages for Saucy, which accounts for the error you received. While you could potentially rebuild those packages for 12.04, there are almost certainly other dependencies that are not satisfied by what is in that version.

It is possible that someone will backport Unity 8 to that version in the future, but while it is under heavy development, your best bet is to use what the developers are working with.

share|improve this answer
    
is there any way Unity 8 can be run on 12.04? –  Projjol Jul 19 '13 at 6:31
    
I don't think there is at present. If you can not upgrade the system, one option would be to install 13.10 in a VM (e.g. using VirtualBox) and test things from there. –  James Henstridge Jul 19 '13 at 6:34
    
Alright, thanks a lot! i think i'll test things out in VM then. –  Projjol Jul 19 '13 at 7:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.