Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm cross-posting this from the Ubuntu forums as it seems like there's some interest here in this new ultrabook. I'm extremely happy with Ubuntu on it.

Ubuntu 12.04.2 on the new Lenovo Thinkpad T431s

Hi Everyone, I just got the new Thinkpad T431s. It's a great computer. The only downside really is the screen (it's a little washed out, but is one of the rare 1600x900 resolution 14” inch ones, so I let it slide). I just wanted to share what I did to get Ubuntu running on it with pretty much all of the hardware functioning and possibly save someone some time.

BIOS Settings: I had a little trouble getting the partitioning correct. My model has a 24 GB SSD and a 320 GB hard drive. This computer ships with UEFI boot and trusted computing enabled. After some trouble, I went in to the BIOS (you have to Fn + Esc to disable the function keys and then F1 to get into the setup). I disabled secure boot and changed it from UEFI to Legacy Boot Only. Then I booted into the installer and partitioned the drives as follows:

On the Hard Drive

  • 2 MB Bootloader Partition
  • 315 GB EXT4 Partion for /home
  • 5 GB Swap Partition

On the SSD:

  • 24 GB EXT4 Partition for /

This seemed to work (trying to set the EFI boot partition kept leading to errors). Then I went through all of the installation process. Keep in mind that if you want to log in using the fingerprint reader, you can't encrypt your /home directory (or you can, it just means that you'll also have to enter the password in addition to the finger swipe).

Network: As installed, the wireless card doesn't show up (it's an intel centrino 6235N). I connected to my local network via an Ethernet connection and ran all of the system updates. Once the 3.5.x Kernel was installed, the network card was recognized. The connection was a little flaky as some people have noticed with this card, so I disabled N networking via the following procedure:

http://askubuntu.com/questions/28244...dvanced-n-6235

It now works fine.

Fingerprint Reader: Fingerprint-GUI needed a little help via the following procedure:

http://askubuntu.com/questions/19352...t430s-in-12-04

After following the steps in the top answer, it worked fine. Keep in mind that as mentioned above, if you encrypt your home directory, you will still have to enter a password to log in. Also, if you log in via the fingerprint reader, you will still have to enter a password for you keyring, unless you want to get rid of the password on that (not recommended):

How can I stop being prompted to unlock the 'default' keyring on boot?

Everything else seems to work fine out of the box (including the camera and the SD card reader). The trackpad doesn't work like it does in Windows, however. The top row of “keys” meant to go with the tracking nub do not map as they do in Windows. Edge scrolling and two-finger scrolling do work.

Overall, it's a pretty great little ultrabook and pretty Linux compatible.

EDIT:

I did one more thing to get the hardware working better. I was a little dissatisfied with the way that the multitouch was working (I wanted a middle mouse button three-finger click), so I went with the following procedure:

First, I created the following directory in /etc/X11, /etc/X11/xorg.conf.d and then a configuration file that runs when X is started, touchpad.conf, with the following lines:

Section "InputClass"
    Identifier      "Touchpad"                      # required
    MatchIsTouchpad "on"                            # required
    Driver          "synaptics"                     # required
    Option          "MinSpeed"              "0.5"
    Option          "MaxSpeed"              "1.0"
    Option          "AccelFactor"           "0.075"
    Option          "TapButton1"            "1"     # left click with one finger tap
    Option          "TapButton2"            "3"     # right click with two finger tap
    Option          "TapButton3"            "2"     # middle click with three finger tap
    Option          "VertTwoFingerScroll"   "1"     # two finger vert scroll
    Option          "HorizTwoFingerScroll"  "1"     # two finger horz scroll
    Option          "MaxTapTime"            "250" # alter this to get good multifinger tap recognition, this is what worked well for me
    Option          "FastTaps"              "1"
    Option          "HorizEdgeScroll"       "1"
    Option          "PalmDetect"            "1" # detects palm touches while typing
EndSection

Any other tweaks you want can be found here:

http://linux.die.net/man/5/synaptics

Then you have to disable gnome control of the touchpad by first installing dconf editor through the software store.

Uncheck "active" in org > gnome > settings-daemon > mouse

This gets two finger scrolling, multfinger clicks and everything else working well.

Adding a startup Application with the following line"syndaemon -i 0.5 -d" restores the disable touchpad while typing.

share|improve this question

closed as unclear what you're asking by guntbert, Warren Hill, Rinzwind, Eric Carvalho, belacqua May 2 at 19:47

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Welcome to AskUbuntu! If you want to share your knowledge, please Ask a question and answer to it. Now it is hard (may be not, just too many letters) to figure out what is the problem and how to solve it. Thanks. –  Danatela Jul 19 '13 at 3:36
    
So, what is question? –  Emin Mastizada Mar 15 at 4:38
    
(Late reply) there isn't - OP is just reposting information on a different website. –  Ads20000 Apr 15 at 8:57