Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The only thing I really miss in Unity is being able to have the notification/indicator icons available I choose. I always have a little CPU indicator, Weather, Opera and Skype available, but in Unity the only one working is strangely enough Skype. Not even HPlipGui's notification icon shows up. What determines what works, and is there a way I can add the ones that do not show up?

share|improve this question

4 Answers 4

Unity does not allow regular notification icons, because they are no longer supported. You can have them show up if you add them to the whitelist (this has been asked before, here is the answer ).

Skype shows up because the developers decided to whitelist it since so many people use it. Personally I disagree with this move because Skype LLC has abandoned linux development outside of Skype Kit, and linux distributions should stop giving them support in their nonsense.

share|improve this answer
    
For me it's simple: If I do not have Skype available on Linux I will have to use another OS. It's a work requirement for me. I'll find the whitelist. I do not like someone deciding how programs I use a lot are to behave. –  user13058 Mar 27 '11 at 1:48
1  
I found how to whitelist: In a terminal enter: gsettings set com.canonical.Unity.Panel systray-whitelist "['JavaEmbeddedFrame', 'Wine','Skype','Opera']" –  user13058 Mar 27 '11 at 7:29
3  
@Christian: "I do not like someone deciding how programs I use a lot are to behave", but you still use Skype?? –  steabert Mar 28 '11 at 11:41

indicator-weather is broken at the moment but a fix should be released any day now. If you already have it installed, it is actually in your panel but its icon only 1px wide. Click on one of the other indicators, and press the left arrow until indicator-weather's menu appears. Set up your location in the preferences window, and finally the indicator should appear properly with the weather!

share|improve this answer

There is an "indicator-sysmonitor

SysMonitor is available to install by a ppa https://launchpad.net/~alexeftimie/+archive/ppa (Natty only)

or by downloading a .deb package from the project homepage @ https://launchpad.net/indicator-sysmonitor/+download

share|improve this answer

By default Unity doesn't show all the tray icons. You can change that using dconf-editor. If you don't have it installed, do sudo apt-get install dconf-editor. Then do the following steps:

  1. Alt + F2 and enter dconf-editor to open it.
  2. Locate desktop > unity > panel
  3. Erase the systray-whitelist value and enter ['all']

That should do it.

For the system monitor, do sudo apt-get install indicator-multiload e restart the session.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.