Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have recently installed steam and Dota 2 on my Ubuntu box. I would like to use my external monitor to get the "full experience". The problem is that when I use the fullscreen option I get the game on fullscreen on my laptop screen. I have checked "Make this the primary display for the X Screen" for external display in NVidia X Server Settings.

What else can I do to use my external monitor for fullscreen gaming ?

share|improve this question

4 Answers 4

I had this problem, still have it I guess. The only way I was able to fix it was to make the monitor I wanted the game on to start at pixel 0,0. My 19" 4:3 was on the left and my 22" 16:9 was on the right and Dota 2 was forever launching on the left monitor no matter where I put the launcher.

I swapped the monitors (logically, mind you), so that the 22" 16:9 was on the left beginning at 0,0 and Dota2 launched on the widescreen properly.

share|improve this answer

I was able to get it working in Ubuntu 14.04 under the display settings under "Launcher Placement" selecting the monitor I wanted my apps to launch on. Hope this helps! Now Dota 2 launches on my primary full screen! WEWT

share|improve this answer
    
Can't test it now but I'll try it for sure:) –  Patryk Jun 14 at 21:39

I have a similar problem. I'm using a dual monitor desktop with the most recent Nvidia drivers available, and I'm also using Ubuntu 13.04.

I have my main monitor selected on my Nvidia-settings and all the other games run on this screen perfectly, but I can't get Dota 2 (the new release, not the Dota 2 -test) to run on my main screen. Every time I select fullscreen it goes to the wrong monitor.

What I am doing is running the game in a lower resolution and in windowed mode. This way I can just drag it to the main screen. If I use my real resolution, the upper and left bar of Ubuntu won't let me fit the screen properly.

This is not a solution, but in the meantime there is no other way.

It looks like it should be simple enough to force the game to run on my main screen, but I'm also new to Linux.

share|improve this answer
    
I am doing the same thing as you. Hopefully someone with a solution answer this question :( –  Patryk Jul 19 '13 at 11:22

As a better solution I may suggest to turn off the external monitor for a while, launch Dota 2 and then alt-tab and turn on your external monitor back. I am an amd-user, so cannot test this idea. Please let me know if it works.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.