Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am just starting with Linux. I have noticed that though Gnome has a fixed menu (Gnome panel) at the top of the screen, similarly to Mac OS X, it is impossible to click a menu item after moving the mouse all the way up, to the very edge of the screen. It looks as if there is a one pixel border between the menu and the screen top edge. Is it possible to remove it?

share|improve this question
    
I don't know about this bug as I haven't experienced this in all the versions and distros that I have used before. But if you can't find a way to fix it, you can reach the menu by pressing the [Alt][F1] combo keys, which will open and give focus to the "Applications" menu. –  Geppettvs D'Constanzo Mar 26 '11 at 16:19
    
@Geppettvs D'Constanzo: Sorry, I probably badly expressed myself. I can click the menu items, this is not a problem. The problem is that if the mouse is at the very top of the screen, it is not above the menu any more. As if there was a border of 1 pixel around the menu. When I click the border, the menu items are not clicked. Funny enough: there is the same "border" to the left from the Gnome menu. However, if the mouse is in the top left corner---i.e. both at the left and top borders,---the "Applications" is actually clicked. –  texnic Mar 30 '11 at 8:03
    
I have just discovered a funny feature. If the active window is not maximized, clicking at the top edge of the screen ("border" above the Gnome menu) maximizes it! I wonder if it is a feature or a bug :) –  texnic Mar 30 '11 at 8:15
    
Thank you for the feedback. And thank you for your self answer. I some weeks ago was looking for a tool like Aero Snap for Ubuntu. Which I give for solved by having your feedback right here. –  Geppettvs D'Constanzo Mar 30 '11 at 16:11

1 Answer 1

up vote 2 down vote accepted

Resolved. The problem (or, rather, the reason) was that I had enabled Windows 7-like window maximize feature (maximize window by dragging it to the top of the screen), as explained here. Having switched it off, I can now use the Gnome menu with the mouse all the way up and left.

share|improve this answer
1  
Glad you found the fix. I had the same problem with clicking the top-left and top-right pixels of my screen why I set some Mac-like corners in Compiz. –  michaelms Mar 30 '11 at 17:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.