Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an openGL app (Heroes Of Newerth) that is usually running in full screen mode. The app launches and runs as expected but when I close the game my X-server crashes. Well I am actually not even sure about that.

All other programs continue to work in the background (like music player). Also I can still see AND move my mouse. Here are the things I tried:

  • I tried ctrl+alt+del but it has no effect.
  • I tried ctrl+alt+F1 to change into another tty console but that didn't work either.
  • I ran sudo aticonfig --initial and it generated me a new xorg.conf file. But the error still presists.

The last lines of my /var/log/Xorg.failsafe.log are:

[ 12151.369] (EE) fglrx(0): DAL initialization failed!
[ 12151.369] (EE) fglrx(0): Display Infrastructure Failed
[ 12151.369] (EE) fglrx(0): PreInit failed
[ 12151.369] (II) fglrx(0): === [xdl_xs113_atiddxPreInit] === end
[ 12151.477] (II) UnloadModule: "fglrx"
[ 12151.477] (II) UnloadSubModule: "fb"
[ 12151.477] (II) Unloading fb
[ 12151.477] (II) UnloadSubModule: "vbe"
[ 12151.477] (II) Unloading vbe
[ 12151.477] (II) UnloadSubModule: "fglrxdrm"
[ 12151.477] (II) Unloading fglrxdrm
[ 12151.477] (II) UnloadSubModule: "vgahw"
[ 12151.477] (II) Unloading vgahw
[ 12151.477] (II) UnloadSubModule: "fglrxdrm"
[ 12151.477] (EE) Screen(s) found, but none have a usable configuration.
[ 12151.477] 
Fatal server error:
[ 12151.477] no screens found
[ 12151.477] (EE) 
Please consult the The X.Org Foundation support 
     at http://wiki.x.org
 for help. 
[ 12151.477] (EE) Please also check the log file at "/var/log/Xorg.failsafe.log" for additional information.
[ 12151.477] (EE) 
[ 12151.480] Server terminated with error (1). Closing log file.

Why is it unloading all the modules? I have an AMD Radeon HD 7500M/7600M Series graphic card with the FireGL proprietary video driver I installed over jockey. Here are some additional command outputs and config files

Edit: I saw a post here with simmilar issue and it apparently got fixed by Linux Kernel 3.7. My uname -r outputs 3.5.0-36-generic. I am using Ubuntu 12.04.

Is this a configuration problem of my X-server? Or lays the error within the software I'm using?

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.