Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed some fonts (mingliu.ttc) by putting them in ~/.fonts/

The font is visible in other applications (such as Abiword & Firefox).

But it does not appear in the font menu of LibreOffice. When I type the font name manually, the characters display as squares.

How can I install the font for LibreOffice?

share|improve this question
up vote 6 down vote accepted

That's weird. I just tried with the same font (mingliu.ttc) and it worked fine in LibreOffice on Ubuntu 10.10.

There might be a problem with your font cache.

Try running sudo fc-cache -f -v. This will rebuild the cache.

share|improve this answer
I deleted ~/.fontconfig manually and run fc-cache again.It works now. – user13030 Mar 27 '11 at 3:43

I had similar font problems with LibreOffice Version and lubuntu 15.04. I checked the permission of the font files in /usr/share/fonts/ folder, changed the permission from 600 to 744, and used the terminal command "sudo fc-cache -fv". It solved my problems, therefore, ownership of the font can be a cause of the problem.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.