Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I own a Western Digital Hard Drive external with power supply 1 terabyte capacity. Today i attached it to my cousin's pc and copied some files from his pc as back up, and since then my hard drive is showing as corrupted once i tried to click it.

So after many attempts to open it , i logged into ubuntu and tried again. Here is the error message i get

Error mounting: mount exited with exit code 13: ntfs_mapping_pairs_decompress() failed: >Input/output error Failed to load $MFT: Input/output error Failed to mount '/dev/sdb1': Input/output error NTFS is either inconsistent, or there is a hardware fault, or it's a SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows then reboot into Windows twice. The usage of the /f parameter is very important! If the device is a SoftRAID/FakeRAID then first activate it and mount a different device under the /dev/mapper/ directory, (e.g. /dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation for more details.

I have more than 700 gigs of data which are mainly photos. I never want to lose them , as they are my past 15 years of life. I wish you guys help me fixing this issue. I am a newbie and a doctor and i know little less about command prompts. Thank you, regards

share|improve this question
    
Thanks for the answer , but it is not opening either in ubuntu too , thats why i posted it here. SO i have to enter command prompt while booting or after boot ????? –  Envira Phani Jul 16 '13 at 18:04
    
This seems to be a hardware problem; I recommend asking somewhere like Super User where hardware issues are supported even when they aren't fundamentally tied to any particular OS or software. Good luck! –  Eliah Kagan Jul 17 '13 at 6:56
add comment

closed as off-topic by user68186, Eliah Kagan, Basharat Sial, Eric Carvalho, Stephen Myall Jul 17 '13 at 15:44

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This is not about Ubuntu. Questions about other Linux distributions can be asked on Unix & Linux, those about Windows on Super User, those about Apple products on Ask Different and generic programming questions on Stack Overflow." – user68186, Eliah Kagan, Basharat Sial, Eric Carvalho, Stephen Myall
If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

up vote 0 down vote accepted

Please clarify (if you know) whether the disk was indeed formatted as NTFS, and if possible give the model number of the drive.

Many older high-capacity external drives used two 2.5" disks in a SPAN configuration to build a single large volume. If you have access to other computers, try mounting the drive on them. If that consistently fails, you still may be able to repair it (unmounted) with Disk Utility in Ubuntu or by using the Run command (Start Menu) in Windows with chkdsk X: /f where X is the drive letter (E: or the like) of the drive.

I have also seen cases where the power supply for drives have partially failed and still provide power but not enough to have the drive work properly. It also could be a failure of the bridge chipset in the drive enclosure. In either of these cases, the data on the drive(s) are still intact though there may be some directory issues that can be fixed. Replacing the power supply or moving the drive(s) to a new enclosure is relatively easy and inexpensive.

Worst-case scenario is that the drive(s) have physically failed and you will need to investigate professional data recovery services ($$$$$).

share|improve this answer
    
Thanks for detailed explanation , i will try the chkdisk option in windows. Infact i never want to lose the pics which are really important for me. The model is this : wdc.com/en/products/products.aspx?id=260 –  Envira Phani Jul 16 '13 at 18:17
    
Hello the chkdsk helped me , thanks a lot for the fix :) , i got my drive back :) –  Envira Phani Jul 16 '13 at 19:00
    
You're welcome. The take-away from this should be that you need a backup of those files. –  douggro Jul 17 '13 at 14:24
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.