Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was using my wired broadband connection perfectly with windows. That broadband uses static ip. At windows 7 the setup was done in IPv4 section.

That had following things:

i) Ip Address

ii) Subnetmask

iii) Default Gateway ---------|

iv) Preferred DNS Server --| - I don't know why this two were same address

v) Alternate DNS Server

Now without any of this, the network will not work, they will show the presence of the network but Mozilla will say, "Server not found"

Now, after I switched and decided to be on Ubuntu, I needed to setup static IP, I did everything this tutorial said, but it returned with "Server not found" Please help me.

share|improve this question
add comment

1 Answer

Start nm-connection-editor in Terminal with

    gksu nm-connection-editor

Ethernet tab: 1. choose offered MAC address

IPv4 Settings tab:

Method: Manual

Addresses: Click on Add

Address: Your static address provided by provider...

Netmask: 255.255.255.0

Gateway: local address of Your modem/router

DNS servers: 8.8.8.8,8.8.4.4 or any other either provided by provider or of Your choice Search domains: google.com or any other either provided by provider or of Your choice

IPv6 Settings tab: similar to IPv4 (consult Your provider, I do not have IPv6 working yet...)

Be sure to choose also previous connection created either automatically or manually and un-check Automatically in General tab... Save that all... Restart NM and You should be done... In rare occasions reboot is the only way to make NM obey this new arrangement...

If this does not help You could always try /etc/network/interfaces a.k.a. ifupdown approach... Just ask and that could be explained also...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.