Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Ubuntu Software Center does not open, I tried these instructions to fix it but they didn't work When I run software-center command from a bash terminal, it still give me the next error.

2013-07-16 13:28:18,591 - - INFO - setting up proxy 'None'
2013-07-16 13:28:18,654 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/lib/python2.7/dist-packages/dbus/', 410, '_introspect_error_handler')'
2013-07-16 13:28:18,653 - dbus.proxies - ERROR - Introspect error on com.ubuntu.sso:/com/ubuntu/sso/credentials: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.Spawn.ChildExited: Process /usr/lib/ubuntu-sso-client/ubuntu-sso-login exited with status 1
Traceback (most recent call last):
  File "/usr/bin/software-center", line 130, in <module>
    app = SoftwareCenterAppGtk3(options, args)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/", line 338, in __init__
  File "/usr/share/software-center/softwarecenter/ui/gtk3/session/", line 66, in __init__
    self.oauth_token = helper.find_oauth_token_sync()
  File "/usr/share/software-center/softwarecenter/backend/", line 141, in find_oauth_token_sync
  File "/usr/share/software-center/softwarecenter/backend/login_impl/", line 75, in find_credentials
    self.proxy.find_credentials(self.appname, self._get_params())
  File "/usr/lib/python2.7/dist-packages/dbus/", line 70, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.7/dist-packages/dbus/", line 145, in __call__
  File "/usr/lib/python2.7/dist-packages/dbus/", line 651, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.Spawn.ChildExited:

I found that this error was produced after install google-api-python-client using this command:

sudo easy_install --upgrade google-api-python-client

It seems that it messed up with some httplib. I still don't know how to correct this error (or install this package correctly). I had to reinstall Ubuntu and do not install the api to avoid the problem.

I would be grateful if someone could help me.

share|improve this question

closed as off-topic by Braiam, Maythux, Eric Carvalho, Avinash Raj, souravc Feb 7 '14 at 16:47

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Braiam, Maythux, Eric Carvalho, Avinash Raj, souravc
If this question can be reworded to fit the rules in the help center, please edit the question.

Looks like this software-center bug – Jason Conti Jul 16 '13 at 17:53
Check this link <>; – Ahmadgeo Jul 16 '13 at 18:03

1 Answer 1

permissions in your python packages are possibly not working.

sudo chown -R $USER:$USER /usr/local/lib/python2.7/dist-packages/

where you can replace $USER with your login name (the one in lowercase).

or preferably the same for just the packages it is complaining about

share|improve this answer
solved my problem .. thank you – M.Sameer Sep 12 '13 at 12:39
This will not fix it for other user accounts, better: sudo chmod -R +rx /usr/local/lib/python2.7/dist-packages/ – Sneetsher Jul 14 '14 at 21:39

Not the answer you're looking for? Browse other questions tagged or ask your own question.