Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Where is my Ubuntu desktop? Its booting and going always default to terminal screen, if i press Ctrl+Alt+F7 still in terminal Ctrl+Alt+F1 still in terminal.

enter image description here

No GUI, how do I recover it?

EDIT:

sun@e700gent:/etc/X11$ sudo apt-get install --reinstall ubuntu-desktop
[sudo] password for sun: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libcdio-paranoia1 packagekit-backend-aptcc gdebi-core libxrandr-ltsq2 linux-headers-3.5.0-23-generic linux-headers-3.5.0-23 libcdio-cdda1 libllvm3.1
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 209 not upgraded.
Need to get 0 B/4,016 B of archives.
After this operation, 0 B of additional disk space will be used.
(Reading database ... 230006 files and directories currently installed.)
Preparing to replace ubuntu-desktop 1.267.1 (using .../ubuntu-desktop_1.267.1_amd64.deb) ...
Unpacking replacement ubuntu-desktop ...
Setting up ubuntu-desktop (1.267.1) ...

sun@e700gent:~$ unity --reset
WARNING: no DISPLAY variable set, setting it to :0

(process:2541): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
//bin/dbus-launch terminated abnormally with the following error: Autolaunch error: X11 initialization failed.

WARNING: environment is incorrect: No D-BUS daemon running

Did you just try to reset in a tty?
unity-panel-service: no process found
compiz (core) - Fatal: Couldn't open display :0




sun@e700gent:~$ sudo startx
[sudo] password for sun: 


X.Org X Server 1.11.3
Release Date: 2011-12-16
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.42-37-generic x86_64 Ubuntu
Current Operating System: Linux e700gent 3.5.0-36-generic #57~precise1-Ubuntu SMP Thu Jun 20 18:21:09 UTC 2013 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.5.0-36-generic.efi.signed root=UUID=68af0547-17ed-4a85-8369-244d57223f91 ro quiet splash vt.handoff=7
Build Date: 11 April 2013  01:05:39PM
xorg-server 2:1.11.4-0ubuntu10.13 (For technical support please see http://www.ubuntu.com/support) 
Current version of pixman: 0.24.4
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Jul 16 17:37:57 2013
(==) Using system config directory "/usr/share/X11/xorg.conf.d"

Fatal server error:
no screens found

Please consult the The X.Org Foundation support 
     at http://wiki.x.org
 for help. 
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

 ddxSigGiveUp: Closing log
Server terminated with error (1). Closing log file.

EDIT:

It seems like solving this problem is like rocket science, its unfixed. Instead of wasting time debugging it, i finally re-install the ubuntu.

share|improve this question
    
Try sudo startx what happens? –  Mitch Jul 16 '13 at 15:37
    
@Mitch: FAILS (no luck) –  YumYumYum Jul 16 '13 at 15:38
    
Please post the contents of /var/log/Xorg.0.log to pastebin and link it. Without having any clue what could be wrong, you could try to move /etc/X11/xorg.conf and all files in /etc/X11/xorg.conf.d to a backup directory. –  soulsource Jul 16 '13 at 15:44
    
@soulsource: here plz find: paste.ubuntu.com/5881280 –  YumYumYum Jul 16 '13 at 15:52
    
This is strange. It seems that the Intel graphics card driver does not find, or more probable, cannot use your graphics chip. What happened before your system stopped working? Is the hardware detection at least correct, meaning, is it an Intel graphics chip? –  soulsource Jul 16 '13 at 17:18

4 Answers 4

Try this. Just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command(s) below:

sudo apt-get install --reinstall ubuntu-desktop
share|improve this answer
    
I have SSH access and CTRL+ALT+F1 terminal access only. There i have done also reinstall of ubuntu-desktop. After reboot still same. –  YumYumYum Jul 16 '13 at 15:48
    
@YumYumYum - what display manager did you have before ?! go to protected mode as root then do try reinstall of different packages: –  dschinn1001 Jul 16 '13 at 15:57

when I encounter this on my machine I simply delete the /etc/X11/xorg.conf and restart the system. BUT - I always make backups! :)

share|improve this answer
    
Dont had any xorg.conf file even. –  YumYumYum Jul 16 '13 at 15:48
    
hm.. you can try this :: sudo dpkg-reconfigure xserver-xorg but please be carefull, or try to see what youtube is showing on this topic. –  Rodislav Jul 16 '13 at 16:00
    
Tried did not solved, wired –  YumYumYum Jul 17 '13 at 7:17
1  
I just built a new computer, took the hard disk from my laptop, put it in my new desktop, but couldn't get X working with the new hardware. Deleted the xorg.conf and immediately everything worked perfectly! Thanks! –  Brian Nov 30 '13 at 18:29

What display manager did you have before? Go to protected mode as root with Ctrl + Alt + F1 Then try reinstalling the following packages:

apt-get install --reinstall xorg-xserver*
apt-get install --reinstall gdm
apt-get install --reinstall unity

In case you have a different display manager than gdm, type kdm or lightdm.

I once had that too - regarding nvidia-drivers ...

share|improve this answer
    
FAILED - not working, still boots in the terminal screen, no desktop. –  YumYumYum Jul 16 '13 at 16:35
    
@YumYumYum - you still did not tell, what window-manager you used ? It was unity ? What happens if you install gnome ? or KDE ? –  dschinn1001 Jul 16 '13 at 16:37
    
Unity, default Ubuntu desktop. –  YumYumYum Jul 16 '13 at 16:38
    
@YumYumYum - have you seen my 2nd answer ?! getting closer to solution ? –  dschinn1001 Jul 16 '13 at 19:18

There was posted in ubuntu-forum this here to solve the problem after

"Stopping userspace bootsplash" appears like in your boot-log :

With the proprietary drivers installed they did the following:

alt+ctrl+f1 (To get a terminal) and after login

sudo apt-get clean

sudo apt-get autoclean

sudo apt-get autoremove

sudo dpkg-reconfigure -phigh -a

reboot

Entered Grub recovery mode selected "repair damaged packages"

reboot

Held shft to get to grub menu hit 'e' to enter temporary changes into grub placed 'vmalloc=192MB' next to quiet splash f10

And problem now solved ?!

They then made the change permanent by editing the /etc/default/grub to include:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash vmalloc=192MB"

Maybe this solves your problem ? Let me know !

share|improve this answer
    
@YumYumYum - you have settled the rest after reboot ? –  dschinn1001 Jul 16 '13 at 21:48
    
no - it is the grub repair modus - when pressing shift - not reaching this ? "recovery mode" ? - well, but thats already much ! now supergrub-CD would help ?! –  dschinn1001 Jul 16 '13 at 21:55
    
Step 1: clean/autoclean/all done Step 2: changed the grub settings Step 3: update-grub / update-grub2 is applied. but still i have same problem booting in to terminal no GUI. –  YumYumYum Jul 16 '13 at 21:56
    
have you read that after 2nd reboot ? read the lines slowly. press 'shift' to get to grub menu and hit 'e' (for edit) - read above. –  dschinn1001 Jul 16 '13 at 21:58
    
YES - those are done, basically if you do it after login permanently its same. /etc/default/grub is same by hitting shift/e. –  YumYumYum Jul 16 '13 at 21:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.