Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After I updated to 2.6.35-28, my Plymouth graphics still works, but when the system tries to launch X11 and GDM, the screen would flicker several times and it will fall back to TTY.

In the TTY screen, above the login prompt is this message:

Can not find sep2_1-x32-2.6.35-28-genericsmp.ko in . directory.  Compile from source.

well, that's the gist of it anyway. I can still use my 2.6.36-27. Though I have no idea what's causing this. When I upgrade to 2.6.36-27, at first i had similar problems where GDM couldn't start, though it didn't have this error message, it just said Xorg crashed.

share|improve this question

closed as off topic by Jorge Castro, fossfreedom Dec 1 '12 at 21:27

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Try running this command: sudo apt-get install --reinstall linux-image-2.6.35-28-generic –  Bilal Akhtar Mar 26 '11 at 9:21
    
I can't suggest a solution, but from the changelog I see that in 2.6.35-28 there has been another "Bump ABI" (see link for details), so I guess that would require a new version for several kernel modules. –  bitwelder Mar 26 '11 at 10:42
    
I tried reinstall, and got this error message: Examining /etc/kernel/postinst.d. run-parts: executing /etc/kernel/postinst.d/dkms 2.6.35-28-generic /boot/vmlinuz-2.6.35-28-generic * dkms: running auto installation service for kernel 2.6.35-28-generic * vboxhost (4.0.4)... [fail] * fglrx (8.821)... [fail] dkms: WARNING: linux headers are missing, which may explain the above failures. please install the linux-headers-2.6.35-28-generic package to fix this. what caused this? –  hansioux Mar 27 '11 at 16:52
    
This question should instead be filed as a bug report, and as such is off-topic, thanks! Instructions on filing a bug report are here. –  Jorge Castro Dec 1 '12 at 20:31
    
yes, there should be a bug report filed, but that wouldn't help with the immediate need to restore functionalities. These are completely different issues, and Mod seems to be mixing the two up. So how is one to resolve this issue when they come on AskUbuntu to search for what to do next? Have them wait for a couple of months till the fix is released? Besides, the final solution has nothing to do with bugs. –  hansioux Mar 18 '13 at 7:09

1 Answer 1

Ok, I found the reason... Sort of. For some reason the header file is not installed.

So without the header files the modules were unable to update. Causing the fglrx driver to fail during start up.

So I just need to sudo apt-get install linux-headers-2.6.35-28-generic and things were resolved.

share|improve this answer
    
On my work computer I have the same issue. The computer at home runs ATI, that problem was fixed after reinstalling linux header and image files. But the work computer still can't boot into GDM even after those two steps and shows the exact same error. –  hansioux Mar 29 '11 at 16:01

Not the answer you're looking for? Browse other questions tagged or ask your own question.