Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

And, once again, my Android device won't connect and I have to work through some complicated set of procedures to get it working. Sorry to be bitter, but I've now been through this too many times. It seems like with each upgrade of either Ubuntu or Android, everything stops working and once again I have to learn a whole new set of configurations I've never seen before and won't see again.

In any case, I've never got MTP to work, I've only ever got it to connect by USB mass storage, which was how it was working most recently. But now, since 13.04, it seems that option has been taken away entirely.

It is unbelievably frustrating, but I need to be able to connect by USB to transfer files, so here I go again...

When I plug in the device I get an error that says Unable to open MTP device '[usb:002,003]':

enter image description here

After some web searching, I found that I might need a program called go-mtpfs, so I tried that, and it failed:

$ go-mtpfs /media/MyAndroid
2013/07/16 16:41:43 compiled against libmtp 1.1.5
Device 0 (VID=04e8 and PID=685e) is a Samsung Galaxy Y.
2013/07/16 16:41:43 found device Samsung: Galaxy Y (04e8:685e) @ bus 2, dev 3
: 
LIBMTP PANIC: Unable to find interface & endpoints of device
2013/07/16 16:41:43 rdev.open failed: open: open returned nil

It really shouldn't be this complicated, but I am trying very hard not to rant...

How do I get my USB device to just connect, automatically, like it used to?

share|improve this question
    
install cyanogenmod and get rid of this MTP crap. You cannot get to work what basically is still under development (MTP). cyanogen mod uses some different filesystem or a fslayer (dunno for sure). In conclusion I know your problem very good, I tried many solutions. Now I am using cyanogenmod and have no problems at all. I can connect to my Android via USB, Bluetooth and at home I use Samba Filesharing to have access to my android via network (WLAN). This way I don't even need to connect it via usb. –  mondjunge Jul 16 '13 at 8:08
2  
@mondjunge: I would be happy to "get rid of this MTP crap". It has never worked smoothly for me, and I don't know why it keeps getting imposed on me by Ubuntu and/or Android. However, I'd like to not have to reformat and reinstall a whole new OS on my phone if I can avoid it. I've done that before and accidentally bricked a phone one time. So I'll keep that as a last resort option and hopefully someone can suggest something with less risk. –  Dave M G Jul 16 '13 at 8:20
    
before I rooted my devices (LG Google Nexus 4) I tried with the solution provided here: webupd8.org/2013/01/upgrade-to-gvfs-with-mtp-support-in.html It worked to some extend. Main problem was, that it stopped working from time to time, in the middle of data transfer. –  mondjunge Jul 16 '13 at 13:38

1 Answer 1

On your Galaxy when you plug it in, a notification should pop up in your notification area saying that USB is connected. If you tap it, it should bring up two options. One is use as mtp device and the other is use it as mass storage. Tap mass storage then tap the new notification that pops up and tap the button that says "mount USB storage". It'll pick it up like a thumb drive (or two thumb drives, depending on if you have a memory card.) From then on when you connect it, just tap "mount USB storage" ... or so it works like that on my stock Galaxy S II. Hope it helps!

share|improve this answer
1  
For my new Nexus 4 this only provides me access to the camera directory... –  mondjunge Jul 16 '13 at 13:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.