Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Xubuntu 13.04 and enabled the drivers from fglrx-update for my Radeon HD 5400 Series video card. However, once the login screen comes up, I get a warning from my monitor about the resolution not being supported.

I can change the resolution once I'm logged in, but I keep getting the same warning when I boot up the computer and try to log in.

Most guides/sites I could find about this problem suggest editing xorg.conf, but that file is not present on my system. I tried the solution in http://www.bingshui.org/tech/defining-display-resolutions-in-xubuntu-12-04/ but this caused the system to freeze right before the login screen comes up, and I had to delete the file created when trying that solution.

How to change the screen resolution for the GDM login screen? suggests editing /etc/gdm/Init/Default, but again, there is no gdm directory in /etc.

Is there a way to fix this?

share|improve this question
add comment

1 Answer

Doesn't xubuntu use lightdm by default?

Regardless what you need to do is build the /etc/X11/xorg.conf, by running the following command:

sudo aticonfig --initial

This will make a generic xorg.conf but should do the job. If it still occurs then you may need to do additional (or follow the research you have done) in order to modify that file to your optimal settings.

One extra hint, after logging in use the command 'xrandr' which should display that monitor as "connected" and give a list of supported modes. perhaps use one of those?

If you want to go the DM init script route then according to Run a startup script with lightdm

"You might want to try adding pre-start or post-start scripts to

/etc/init/lightdm.conf (see http://upstart.ubuntu.com/getting-started.html for an introduction to upstart that parses this file)

Also /etc/lightdm.conf allows to specify scripts to be loaded. You have a detailed description of all (many) the options that can be used in the configuration file lightdm.conf at /usr/share/doc/lightdm/lightdm.conf."

For example, for gdm, I resolved an issue by adding the following command to /etc/gdm/init/Default:

if xrandr -q | grep -q "CRT1 disconnected"; then xrandr --output LVDS --mode 1600x900 --pos 0x0 --primary fi

So perhaps you can research into that answer (and the upstart link) to determine if you can add a script which basically does the same thing (tho you won't need the if statement, if only running 1 monitor)...

I had do this modification because after futzing around with xorg.conf to act like I wanted when booting from single monitor (laptop) to multi-monitor, when in single monitor mode, the GDM login screen was using the wrong resolution (it was using the multi-monitor virtual display size... I think), so issuing that BEFORE the initctl command for GDM resolved, and it should resolve for you too (I say should because I haven't looked into lightDM to0 heavily).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.