Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've just installed Ubuntu 10.04 into VirtualBox on Windows 7.

Unfortunately the only options showing for screen resolution are 640x480 and 800x600 and the monitor is showing as 'Unknown'.

How would I go about upping the resolution to 1280x1024 (I'm on a 1600x1200 monitor)?

I tried mounting the VirtualBox 'Guest Additions' ISO (from the VBox 'Devices' menu) and doing sudo sh ./ from the mounted drive, which gave 2 new listed resolutions after a reboot (1024x768 and the 16:9 version of that resolution). These worked when I selected them but disappeared when I switched back to another resolution. I tried rebooting and running again but onlu the 2 low res options listed this time.
I think I'm going to reinstall...

Seems to be a VBox problem rather than an Ubuntu problem as after reinstalling 10.4 overwriting the original virtual partition, sudo sh ./ now has no affect at all.

share|improve this question
What graphics card? It may be an issue with Virtual Box in Windows 7 and/or your graphics card. It works for me on Windows XP with a Radeon HD 5750. – George Marian Aug 28 '10 at 17:10
If you do not use X with VBox (like me), you can use Putty to SSH. The Putty window can be sized. – user8290 Dec 29 '12 at 23:00

16 Answers 16

You need to install the VBox guest utilities to add support for the virtualised graphics hardware.

sudo apt-get install virtualbox-guest-utils virtualbox-guest-x11 virtualbox-guest-dkms

Previously you might have needed the "ose" versions:

sudo apt-get install virtualbox-ose-guest-utils virtualbox-ose-guest-x11 virtualbox-ose-guest-dkms
share|improve this answer
No luck with that I'm afraid. I still only have the 2 low res options in Monitor Preferences :¬( – pelms Aug 28 '10 at 2:40
even after reboot? – maco Aug 28 '10 at 3:41
Yep. Even tried this straight after a fresh install of 10.4 (after the updates) – pelms Aug 28 '10 at 12:42
I think the ose tools are only useful if you're running the OSE edition of Virtualbox.. For the closed source version you should use the most recent ones that can be installed as the OP indicated. – Matti Pastell Dec 10 '10 at 7:02
@MattiPastell I think your comment is outdated, as Oracle has merged the OSE and non-OSE versions of Virtualbox; as of version 4.0, the non-OSE components are added separately with an extension pack. See the VirtualBox website for more info – David LeBauer Jan 9 '12 at 21:55

  1. Start Virtual box and log into Ubuntu.

  2. Hit the right ctrl key so you can get your mouse pointer outside the virtual machine.

3.Go to top of virtual window, click on devices then select "Install Guest Additions" You will see a window pop up inside Ubuntu showing you that there are some new files mounted in a virtual CDROM drive. One of those files should be

You must run the file with some admin permissions so do that this way...

  1. Click inside the Ubuntu screen again then go to Applications - Accessories then Terminal. The terminal window is where you will run the file from, but first we must navigate to the correct directory.

  2. type this... cd /media/cdrom0 (then hit enter, there is a space after cd!)

  3. next type... dir (You should see amongst the files displayed

  4. now type... sudo sh ./ (yes, that is a full stop before the slash!)

after you hit enter and it has done its stuff, the files are now accessable from Ubuntu.

  1. You now need to reboot the virtual machine or press Ctrl+Alt+backspace.

  2. Log onto the Ubuntu desktop and this time go to System - Preferences then Screen Resolution. You should now have more options than the three low res options you had at the beginning of the day!

if the resolution you want is not one of the newly listed ones then follow these steps...

  1. Open the terminal window again (Applications - Accessories then Terminal)

  2. Type... sudo gedit /etc/X11/xorg.conf (space after gedit and X11 must be capital X)

  3. It will ask you for a password which is the same as you log in with.

  4. The text editor loads and you should see a lot of text in the window. First make a backup of this file by going to "file" then "save as" and changing the filename to xorgbak.conf

  5. You now need to hunt through the text until you see the display resolutions listed. The ones you will be concerned about will be listed under bit depth 24 or bit depth 16 (as these depths are the ones that give you a large amount of colors.)

  6. The idea here is to have your favorite screen resolution included in this list. Do this by either inserting it before the other listed resolutions in the exact same manner or typing it over one of the others. (you will only need to do this for the ones under bit depth 24 and 16)

  7. You must now do a "save as" but be careful here as this time we need to call the file xorg.conf again. If you just hit save here you would have saved the changes over the backup file you created!

  8. You are done. Hit Ctrl+Alt+Backspace to restart your virtual box, log in and enjoy your new screen resolution options!

share|improve this answer
Even if this answer might factually be correct (which I don't know), it is hardly readable and therfore will not help that much. Consider using formatting, links and so on. – Bananeweizen Aug 28 '10 at 11:55
Thanks Siamore. At what point do you press 'F8'? It doesn't do anything once Ubuntu has launched. – pelms Aug 28 '10 at 12:56
Why keep marking the guy down..? How many points do you need to be able to edit the post? – pelms Aug 30 '10 at 19:27
@pelms no need to press F8 it should work automatically – Siamore Sep 28 '10 at 11:25
There is NO operation "Install Guest Additions" in devices. You mean "Insert Guest Additions CD" I think. You have to choose the iso by rightclick on the cd image in the right bottom corner, find BY HAND the iso in the virtualBox folder and turn it on. – Gangnus Jun 3 '14 at 9:19

Devices > Install Guest Additions, let it run then log out.

When you've been returned to the login screen you'll see it's the full size of your monitor. Log in and you're good to go.

share|improve this answer
+1 for saying you have to log out after installing GA. That did the trick for me too. – Bennett McElwee Jul 9 '14 at 0:39

I had the same problem and then found out that if you launch the virtual machine > click "view" on the toolbar > click "auto-resize guest display, then your virtual machine will have the same screen resolution as your own screen.

share|improve this answer
this is the simple trick! thank you :) – user1291235 Jul 29 '13 at 7:20
I've been trying to fix that for a while. Can't believe I was missing something so obvious. Thanks man – o0rebelious0o Jul 30 '13 at 9:10
The auto-resize guest option is greyed out. – Ron Smith Sep 17 '14 at 4:47

Once the Vbox Additions has been instaled (and reboot the guest os), press Host + H, then maximise the window, thats sould do the trick..
If not, maybe you are using an old version of vbox (therefore, the Vbox Additions might has an incompatibility..)

share|improve this answer
At least in the latest version of Virtual Box (4.2.16), it is [Host] + [F]. In my case, I just need to press this two times (activating & deactivating) for having Ubuntu displayed in the maximum resolution. – ComFreek Sep 6 '13 at 17:48

Try increasing the amount of RAM allocated to the Virtual Box. Worked for me.

To do this, stop the VM, then in VirtualBox go to the Settings for the VM. Go to the Display section. You can increase the Video Memory there. Mine was 1MB; I increased it to 32MB and that allowed me to use my 24" monitor fully.

share|improve this answer
Can you provide instructions on how to do this? Please edit them into your answer. – Seth Apr 26 '14 at 1:00
I have added instructions to the answer, based on my own hard-won experience. – Bennett McElwee Jul 14 '14 at 0:31

I can tell you how I do this with Mac OS X as the host system. Maybe it will work on Windows too.

  • I start ubuntu in VirtualBox
  • I open up the terminal on Mac OS X
  • and execute "VBoxManage controlvm [name] setvideomodehint 1280 1024 24" (replace [name] with the name of your ubuntu vm)
share|improve this answer
And then what do you do? Do you see the change immediately? Do you restart the VM? Do you have to click something? Is Guest Additions required first? – Volomike Jan 13 '13 at 14:52
I'm sorry I can't remember anymore (it's been a while) :-) – user142 Jan 18 '13 at 20:31
Yes, the change happens immediately. – Ejoso Dec 19 '15 at 0:39

I had the same problem and was able to fix it by using the xrandr utility. I followed this article to fix the issue.

Sometimes this may help you. Give it a try.

share|improve this answer

I was able to fix this problem by shutting down my VirtualBox virtual machines, quitting VirtualBox, and running this command in a Terminal:

VBoxManage setextradata global GUI/MaxGuestResolution any

Then start VirtualBox back up and the problem should be fixed!

share|improve this answer
  • Settings > Video > Video Memory = 128 MB, Enable 3D acceleration = true.
  • Install GuestAdditions
  • On Host machine, in cmd/bash, run

    VBoxManage setextradata global GUI/MaxGuestResolution any
  • create /etc/X11/xorg.conf file with content:

    Section "Device"
      Identifier      "Configured Video Device" 
    Section "Monitor" 
      Identifier      "Configured Monitor"
    Section "Screen"  
      Identifier      "Default Screen" 
      Monitor         "Configured Monitor"
      Device          "Configured Video Device" 
      SubSection "Display"
        Modes "1920x1080" 
  • For running VM:

    Host Key Right Ctrl at default + Home = view full screen.

I have tried to exclude every step except GuestAdditions installation. You need every one of them.

share|improve this answer
What would be the file path in elementary OS Freya? – fleamour Nov 23 '14 at 22:34
@fleamour If your system is different from Ubuntu, I think, you should place it as a separate question and on the different site, sorry. This answer took about 6 hours. I can't even guess, how much will it take on another OS. – Gangnus Nov 24 '14 at 12:03

What driver is specified in ur xorg.conf? AFAIK, after installing guest additions the 'vboxvideo' should be used:

Section "Device"
    Identifier   "Configured Video Device"
    Driver     "vboxvideo"
share|improve this answer

After installing guest additions: Go to settings > Display Increase video memory and enable 2D and 3D video acceleration.

share|improve this answer

It is probable that your brand new install of a linux distro on your Virtualbox is still fresh and that much more needs to be done to set up your environment, not the least of which is to enable the X Window system if all that you are seeing are display settings for 4:3 aspect ratio and entering 'startx' at the command prompt does nothing. your terminal prompt, enter the following:

sudo apt-get install dkms
sudo apt-get update
sudo apt-get install linux-headers-`uname -r`
sudo apt-get install --reinstall xorg

If you had set your virtual machine to fullscreen mode prior to entering 'startx', then the screen will automatically adjust to 16:9 aspect ratio, with tool and task bars in their proper places.

share|improve this answer

This may have already been resolved but I had this issue and fixed it very simply, I just updated VirtualBox to the latest version then re-installed the guest additions.

share|improve this answer

VirtualBox 4.3.12 was preventing the above solutions from working on my Windows system. 4.3.18 was released somewhen around 2014/10/10 (2014 Oct 10), all of the above works since installing that.

The "VBoxManage setextradata global GUI/MaxGuestResolution any" command appeared to work previously, that is to say it didn't throw any errors.

Installing guest additions had previously complained that the header files were not installed, however they absolutely WERE (& have been left untouched) as evidenced by the fact that installing guest additions under 4.3.18 upgrade does not throw the error when building the shared folders module.

share|improve this answer

Following command worked for me
sudo apt-get install dkms

Restart VirtualBox

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.