Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a laptop that I have been dual booting Windows 8 and Ubuntu on for over a month now, but for some reason Ubuntu has stopped booting. Upon powering up the computer GRUB shows up and displays the operating systems as it always has, but when I select Ubuntu I get a black screen with a flashing underscore cursor. I have been racking my brain for causes, but I cannot figure it out. It was working, then it wasn't.

First I tried using the "recovery mode" to fix any issues, but I couldn't even get it to boot into recovery mode. Although I admittedly do not know what was being output to the screen, it kept hanging up on at different points (the numbers ranged from 18 to 100) and the errors read something like "unfriendly input/output error". I tried using the "boot-repair" live CD with no avail. I think one of the primary issues was simply that I couldn't get my computer to connect through the internet even while using an Ethernet cable. I am re-downloading the Ubuntu CD now with the intent of trying to download and install boot-repair as instructed here:

https://help.ubuntu.com/community/RecoveringUbuntuAfterInstallingWindows#Using_the_Ubuntu_Alternate_CD

Any insights as to what caused this or what is wrong? Also, will the boot-repair utility actually repair the damage that has been incurred?

share|improve this question
    
Welcome to AskUbuntu! Does your Windows run normally? And what is the problem with LiveCD? –  Danatela Jul 16 '13 at 3:44
    
Thanks for the quick response Danatela. Yes, windows does run normally. The boot-repair live disk was not able to repair my grub installation using the recommended settings. I get the following error: "grub2 purge cancelled. Please report this message to [email protected]". I downloaded an Ubunutu 12.04 LTS live CD and I just confirmed that I get the same message when connected to the internet. –  Jacob Stockton Jul 16 '13 at 4:04
    
I would love to a screen shot of some of the error codes, but I cannot do so until I am promoted to 10. –  Jacob Stockton Jul 16 '13 at 4:30
    
New development: I can't install ubuntu 12.04 to restore the system either. I consistently get the error "ubipartman failed with exit code 141.Further information can be found in /var/log/syslog." –  Jacob Stockton Jul 16 '13 at 18:36
    
I was able to get boot-repair to output the following: paste.ubuntu.com/5881851 Is there anymore helpful information that could aid you all in helping me? –  Jacob Stockton Jul 16 '13 at 19:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.