Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

problem installing an older version of gcc

Hi,

I'm new to ubuntu:)

I'm trying to compile a program in Matlab using mex (Matlab), but I'm getting an error that I'm using gcc version 4.6.3 and the currently supported version with mex is 4.4.x.

So I downloaded gcc 4.4.3, but when I try to open it using Ubuntu software center, I'm getting an error: Dependency is not satisfiable: gcc-4.4-base (=4.4.3-4ubuntu5.1).

I don't know how to solve this problem. Can anyone please help? any help will be greatly appreciated as I'm quite stuck.

Thanks in advance,

Gil.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

You don't need to download a package manually. Just install it using Software Centre and it will download the appropriate packages for your installation! That's how easy Software Centre works.

Click here: gcc-4.4 Install gcc-4.4.

Then use gcc-4.4 to invoke that specific version. Your gcc will be kept the default version though. If you really need to change the system default, see Choose gcc and g++ version

share|improve this answer
    
thank you for your help! –  user175405 Jul 16 '13 at 13:09
    
@user175405 If this was helpful and solved your issue, consider accepting this answer by using the check mark. –  gertvdijk Jul 16 '13 at 16:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.