Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I made an upgrade from 10.04 to 12.04. It all went smooth, more or less, but at end I have the real problem - my keyboard is not working! I tried both USB/PS2 keyboards, but it's the same story (mouse is working).

So, I can type my password on login screen, and after successful login, I can't use my keyboard at all. What's funny, when I change switch to Guest user keyboard is working. Form that Guest session I can login via "ssh -X" with my user name and keyboard is working perfectly, both in terminal and every program I start. I tried everything I encountered on the web with "keyboard problems in Ubuntu 12.04", but without any solution. I did "upgrade" and "dist-upgrade", I also installed "Gnome" and login into "Gnome-classic" session, but still facing the same problems.

I would be grateful to any help. Thank you in advance!

Best regards, Aleksandar C.

share|improve this question

1 Answer 1

OK, so this is not a real answer, because many things could have gone wrong, but maybe it will help you, and it is too long for a comment. First thing; since your mouse works, you should go to the system settings / keyboard and try to select again your default keyboard. Also, you should attempt to check the keyboard there.

What happened to me a few times was that during upgrade, several of the config files in ~/ did not work or did not work properly. Sometimes it was just too much of a bother to really track down the problem. If that was the case, I did the following (assume that the username is 'foo'):

  1. Log in to a text terminal (ctrl-alt-f1)
  2. Become root with sudo -i
  3. Move the old home to a temp directory

    mv /home/foo /home/foo-backup
    
  4. Create a new home

    mkdir /home/foo
    find /etc/skel/ -exec cp {} . \;
    chown -R foo:foo /home/foo
    
  5. Log in again through the GUI. You now have an empty, vanilla user account. Copy all the files (including configuration files) back to your home directory.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.