Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am admittedly a newbie user. I have recently got an Ubuntu 13.04 install working on my rMBP (as you can infer from the title) and noticed that suspend doesn't work. The system shuts down properly, but will not resume after reopening the lid and/or pressing keys. After some google searching I stumbled upon someone saying that the nvidia driver work with suspend. If there is in fact no solution for me to stick with my nouveau driver and suspend properly, then how may I go about installing the appropriate nvidia driver? Thank you very much in advance.

share|improve this question
    
What Nvidia driver version did you try? What Ubuntu version are you on? What do you mean "will not resume"? What exactly happens? Please edit your question to include more details. –  gertvdijk Jul 15 '13 at 9:47
    
@gertvdijk thank you for the feedback. I have edited my post as requested, but I have not attempted to install the Nvidia driver yet, so I don't have a version. –  NeonPanda Jul 15 '13 at 9:55
    
"I stumbled upon someone saying that the nvidia driver work with suspend" Well. Just try a recent version. For me on my hardware the Nvidia driver works perfectly fine in suspending. Don't just follow one experience of a single user report. And not all installations/hardware are the same, so results always vary. Anyway, so your question is solely based on this "rumour"? –  gertvdijk Jul 15 '13 at 10:07
    
@gertvdijk To be more specific, I read someone else's guide to installing Ubuntu on a MacBook Pro Retina (10.1). This is my specific case so I thought it would work. The only difference was the version of Ubuntu they installed. cberner.com/2012/10/19/… –  NeonPanda Jul 15 '13 at 17:38
    
Bump, I have yet to find the solution to my problem. Any help would be greatly appreciated. –  NeonPanda Jul 16 '13 at 22:24
show 2 more comments

1 Answer

I too faced the same issue. Seems that the nouveau driver for nvidia is buggy. So all you have to do is switch to integrated intel card and disable the nvidia card.

Make sure xserver-xorg-video-intel package is installed

sudo apt-get install xserver-xorg-video-intel 

Switch to the integrated card: I couldn't do that from Linux. [Not sure if there is a simple way in Ubuntu to achieve this] I booted Mac OSX, installed gfxcardstatus app from http://graphic-card-status.mac.informer.com/2.1/ and then set it to "Integrated Only".

Reboot to ubuntu. Suspend/resume should work like a charm

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.