Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I realize this issue is very prevalent - but before you mark this as a duplicate - I have tried everything suggested online, and nothing works.

The problem:

enter image description here

With the Nvidia Quadro K1000M and Ubuntu 12.04 LTS x64 on my Lenovo W530, I have tried sudo apt-get install mesa-utils, I have tried looking under "Additional Drivers" (when opened, this states, "No proprietary drivers are in use on this system), I have tried manually installing the .run file from the Nvidia website (ended up with me getting into some horrible 800x600 resolution and having to edit the xorg.conf file to get out of it). Currently, I have nvidia-settings, -common, -current installed (which I got from Synaptic). The screen has luckily returned to full-screen resolution.

I have been using Linux for 3 days only, so when I was doing all the above, I also had no clue what was actually going on.

If it makes any difference, I have bumblebee installed for Optimus support.

Running Additional Drivers:

enter image description here

More info:

...:~$ glxinfo
name of display: :0.0
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual or fbconfig

Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".

Proof that something is (supposed to be) there:

...:/usr/bin$ ls nv*
nvidia-cuda-mps-control  nvidia-detector   nvidia-persistenced
nvidia-cuda-mps-server   nvidia-installer  nvidia-settings
nvidia-debugdump         nvidia-modprobe   nvidia-uninstall

...:/usr/bin$ nvidia-installer --version

nvidia-installer:  version 319.32  (buildmeister@swio-display-x64-rhel04-14) 
Wed Jun 19 15:50:43 PDT 2013
  The NVIDIA Software Installer for Unix/Linux.

  This program is used to install, upgrade and uninstall The NVIDIA Accelerated
  Graphics Driver Set for Linux-x86_64.

  Copyright (C) 2003 - 2010 NVIDIA Corporation.

But no drivers found at all:

...:~$ jockey-text --list
...:~$ 

Like I said, I am a very new user and I would really like to be able to use Ubuntu, however this problem is making me struggle.

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

Few thing I would like to explain,

Nvidia Optimus is a very tricky to be worked on linux platform.

The thing you need to understand, how it works. In optimus configuration the nvdia hardware isn't connected to the output screen. Only the inbuilt graphics card is attached with the screen. So the OS never detects that there is an nvidia graphics device. (Even windows doesn't detect that, nvidia drivers installed in windows tells windows that the device is an nvdia graphics card. Try running the system rating utility in windows, the score will be always based on the internal graphics card)

Then how it works, in windows whenever the nvidia driver detects a directx call, cuda call it starts the nvidia hardware. The information is passed to nvidia card, nvidia card decode and generate the images and pass then to internal grphaics card for displaying.

So at the end, you will never see nvidia card listed in system details, it should list the internal graphics card

What does bumblebee do - If you didn't install it, in linux both graphics card stays on always leading to high temperature and battery usage and nvidia card never used as the OS doesn't know how to use it. By installing it, it disables the nvidia card, and when you required you can use the nvidia card to some extent (not fully). And it also install the nvidia driver required.

Never install driver from nvidia site for an optimus system. If you go to Addtional Details / Support tab of the download page. It is clearly written This driver doesn't support some models of the graphics card. More specifically, those driver doesn't support optimus configuration.

Installing mesa-utils is enough for detecting the internal graphics driver (mostly the internal gpu is made by intel). At this moment, I think you system is in pretty much mess. I suggest to start with a new installation. Install all updates and bumblebee. Test bumbleebee with optirun. If this works don't worry about what is shown in system details.

share|improve this answer
    
Thanks for the advice. I was starting to get the feeling that everything was all messed up. If I am understanding you correctly, the only thing that Nvidia will be doing is GPU-interfaced calculations made from applications that utilize it, like games? –  VF1 Jul 15 '13 at 4:51
    
Yes correct. In linux device will be used when you used bumblebee and use optirun. For test, run glxspheres in normal (this will use internal GPU) then run optirun glxspheres to see the difference. Also you can run some webgl test on firefox using optirun firefox. :) –  Web-E Jul 15 '13 at 5:26
    
Wow... Thanks for all the help. I did a clean install, and, after re-configuring everything - which was a pain and I should probably make a script for it when I learn how - glxspheres bumped up from 25 Mpixels/sec to 200 Mpixels/sec. –  VF1 Jul 15 '13 at 15:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.