Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

If you select "Recovery Console" at the GDM login screen, you are presented with a terminal screen in the top corner of the screen and the usual GDM background.

I'm trying to diagnose a problem which occurs straight after login where the machine hangs.

Which commands should I run from here and in what order to get myself into the state I would normally be in had I logged in the normal way?

Thanks

share|improve this question

closed as too localized by Jorge Castro, jokerdino, Takkat, fossfreedom, htorque Jan 29 '12 at 21:42

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Difficult to do. You would have to go through the steps in /etc/init/gdm.conf and then launch gdm-binary. But if your machine hangs, how do you hope to diagnose anything? –  steabert Mar 25 '11 at 23:51
    
It hangs quite late in the login process so I would like to see which step is causing the hang, and then use that to try and solve it. –  Slipstream Mar 26 '11 at 11:11
    
Hm, gdm is a binary prgram that's the parent process of the rest of your session. I don't think it's feasible to believe you can easily reproduce steps (AFAIK). As an alternative, does it completely hang or can you access the console with CRTL+ALT+F1? If you can do that or you reboot and access a terminal you can have a look at ~/.xsession-errors. –  steabert Mar 26 '11 at 11:43
    
I've already had a look at .xsession-errors and nothing looked particularly unusual. I solved the problem by erasing the user and re-creating it, but I'm sure the problem will resurface in the future. –  Slipstream Mar 28 '11 at 19:40
    
Turns out it wasn't a problem with xorg at all but a problem with compiz, hence it not showing obviously in any of the xorg logs. Deleting the .compiz folder and restaring X seemed to fix it. –  Slipstream Apr 5 '11 at 15:09