Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Something with my installation of Windows has gone seriously wrong, so I was looking to reinstall Windows 7. However, since I don't have an optical drive on my machine, I was attempting to make a bootable USB drive. The most preferable option would be to use the tool provided by Microsoft, but of course that only works on Windows. I was playing around with some alternative tools to create an install thumbdrive such as WinUSB and UNetbootin, which involved a lot of messing around in gparted as I tried and failed to boot from the USB drive.

Eventually I decided to just create a Windows VM in VirtualBox and utilize Microsoft's own software, except now Windows won't recognize my thumbdrive; I'm getting a fairly generic "Code 10" error when I try to inspect the drive in the device manager. I also tried using it on my Mac, but it won't recognize the device either.

Ordinarily I'd assume that I massively corrupted the drive in some capacity, but I still am able to use it without issue on Ubuntu, so I'm assuming I can still salvage it in some way? I've tried formatting it in FAT/32, NTFS, leaving the space unformatted, etc, but the other OSes still refuse to read it.

Any suggestions on how I can regain access to my thumbdrive on Windows and Mac?

share|improve this question

1 Answer 1

Note : I'm a terminal guy. You could do the following (finding partitions, reformating) using gParted (GUI). By the way, this will erase all data on your key.

First, find the device file to your USB drive. Under Ubuntu, you'll find it using the Disk Utility, which can be found using the Dash. (once opened, click on your key, and find it's device in /dev ; it will probably be something like /dev/sdb).

Once you have it, and once you're sure about it, type :

sudo fdisk /dev/X

X being what you found earlier.

Press p to find the link to your USB partition (it will begin with /dev/X and end with a number ; probably something like /dev/sdb1). Remember it, we'll call this new name Y.

Use w to write changes (none actually...) and quit.

Back in the command line, type :

sudo mkfs.msdos -F 32 /dev/Y

Remember, Y is /dev/* ending with a number (partition link). This will format the key in FAT32.

Once formatting is finished, your clear to go. Unplug/Replug the USB drive to force Ubuntu to remount it.

In the end, if you need a bootable USB drive, use Unetbootin, which is available under Linux. It only requires an ISO image.

share|improve this answer
    
Hey John, thanks for the quick reply. Unfortunately, formatting with mkfs.msdos still results in the same error. Interestingly, my Windows VM is instructing me that I should use the drive with a USB 2.0 port, which it wasn't doing before... I guess that's a little progress any way! –  rsmuckles Jul 14 '13 at 22:55
    
It means it can find it :) But we all know how lazy Windows is... Try to format the key on Windows : start, right click on Computer, Manage (Disk Management in the left panel ; I won't write more help with this OS here ^^). –  John WH Smith Jul 14 '13 at 22:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.