Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

First off, I am very new to Ubuntu, and have installed 13.04 as my sole OS to force myself to try and learn a bit. However, I have run into an issue creating a Unity shortcut.

I have tried to create a .desktop directly to the .jar, but that does not actually open, just thinks for a minute. Code i used is: `

[Desktop Entry]
Name=Feed the Beast
Exec=/home/richard/.ftblauncher/FTB_Launcher.jar
Icon=/home/richard/.ftblauncher/FTB.png
Terminal=false
Type=Application
StartupNotify=true

I have also tried to create a shell for the .jar, then changed the .desktop to reflect the change. the .sh code i used is:

#!/bin/sh
BINDIR="$(dirname "$(readlink -fn "$0")")"
cd "$BINDIR"
export LD_LIBRARY_PATH="/usr/lib/jvm/java-7-openjdk-amd64/jre/lib"
java -Xms2G -Xmx3G -jar ~/.ftblauncher/FTB_Launcher.jar

the .sh runs fine when run from the terminal, but the .desktop tells me "There was an Error Launching the Application"

Please Help, I'll post anything else you guys need. and yes, all are set to "Allow as Executable", however I cannot set Java 7 as default for the .jar

share|improve this question

1 Answer 1

Figured it out! I honestly have no clue what had happened, but I had gone and deleted the files and rewrote the scripts, and now it works. I don't know, I possibly had fat-fingered something along the ways.

Either way, thanks for the help if you were researching it, thanks for viewing at least if you weren't... I'm sure I'll be back here with another stupid question very soon.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.