Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am a newbie here but I will try to be as specific as possible.

Sequence of events:

  1. Selected to upgrade to 12.04LTS from 10.x
  2. As my Internet speed is too low, the packages download time was around 4hrs
  3. Waited for 2hrs but went to sleep after that
  4. Woke up the next day and found the machine switched off.
  5. NOTE: Here, in my city, power failure is very frequent. So it's highly likely that there was a power failure but I am not sure about it. Thus, I can not say if the machine got shut down during download or the next step, which was installation.
  6. Now the machine does not start up. It is stuck at Ubuntu splash screen(Plymouth???).

Efforts from my end towards solving this issue.

  1. The first time boot after I woke up, showed something like /tmp not found or not ready yet. Waited for few mins and pressed enter to continue. After this it is stuck at ubuntu screen with 5 orange circles.

  2. Read some posts and did the following:

    a) Edited grub file... I.e comme Ted hidden timeout. And also commented the default kernel arguments......so "quite splash" are not used.

    b) Rebooted the machine and selected the first entry from the grub menu.

    c) now it's stuck at "starting domain name service ...bind9"

  3. If I press Ctrl-Alt-F1, I can go to the command line login prompt, but I have no clue what I should do there.

  4. Just to check, I tried to run XSane....but it ends with grk warning "cannot open display" which I think is ok...but not sure what to do next to get back to full fledged graphical bootup

Options that I have:

  1. Get help from the forum members and try to solve this......It will be fun as it's for the first time tht I am doing it
  2. Lame way....fresh installation....which I hate to do without trying the first option

Plz let me know how to proceed... Also if u need any more info plz do let me know

P.S.: Advance apologies if any technical jargons are used in an incorrect way. I just found some words in some other posts on the forum and I think those do represent what I want to say.

share|improve this question
Power failures during a distribution upgrade will probably have got your system in an inconsistent state. You really don't want to cut the power during this procedure! If it's feasible, just back up your data while running from a Live CD and then reinstall. It's a lot quicker than upgrading. –  gertvdijk Jul 14 '13 at 14:26
Did you try Recovery mode? You can select it, then go to root with networking, then pass apt-get update && apt-get upgrade or apt-get -f install to the shell. –  Danatela Jul 14 '13 at 15:03
hi...thanks for the quick responses. how do I go to recovery mode with network?? –  sheriv Jul 14 '13 at 18:02
I tried rec mode from grub menu but the nw is not enabled in that. also the network service seems to be not recognized one when I try service network start –  sheriv Jul 14 '13 at 18:12
There must exist drop to root shell prompt with networking or similar option inside recovery menu. –  Danatela Jul 15 '13 at 5:59
add comment

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.