Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On my Ubuntu 12.04, the audio server encounters occasional crashes, so that I'm forced to reboot the system in order to have it play audio.

Alsamixer looks ok, nothing is muted. Moreover, I tried

sudo pkill -9 pulseaudio

and then:

pulseaudio -D

which gave me

E: [pulseaudio] main.c: Daemon startup failed.

Can you help me understand what's wrong?

share|improve this question
    
Could you try again with the -v option to pulseaudio? E.g. pulseaudio -v -D. The final error should come after some other errors. –  gertvdijk Jul 14 '13 at 11:58
    
I've done this and it's the same: pulseaudio -v -D E: [pulseaudio] main.c: Daemon startup failed. –  martina Jul 14 '13 at 13:03

2 Answers 2

Pulseaudio will run on a per-user basis in a default setup. Therefore we do not need root permissions to kill it.

The command to restart/reset a running pulseaudio sound server from a terminal is simply issueing

pulseaudio -k

By doing to the sound server will autospawn and restart immediately in a default setting. You will always get an error if you try to run pulseaudio twice.

To run pulseaudio from command line to read possible errors you will have do temporarily disable the autospawning (see this article for details on how to do this).

Sometimes bad user setting are responsible for a malfunctioning pulseaudio sound server. We may then try to rename the settings directory ~/.pulse (or ./config/pulse in newer releases) before we restart pulseaudio. This directory will then be recreated with default settings.

share|improve this answer
    
Well, ok, I used the -k command to reset it, to no avail. I have: > pulseaudio -k and it says nothing. Now I did: > ps -e | grep pulseaudio and it gives me: > E: [pulseaudio] pid.c: Daemon already running. > E: [pulseaudio] main.c: pa_pid_file_create() failed. Moreover, it can be useful to add that the audio works if I use headphones, while it does not with the computer usual speakers. –  martina Jul 14 '13 at 16:40
    
It may have somehow picked up your headphones as default audio sink. Did you try to rename/delete the ~/.[/config/]pulse directory? To list available sinks you can issue pacmd list-sinks - are your speakers present? –  Takkat Jul 14 '13 at 18:31
    
Giving that list command I get two things: 2 sink(s) available, and they are: name: <alsa_output.pci-0000_00_1b.0.analog-stereo> 09:00:37 PM and name: <alsa_output.pci-0000_01_00.1.hdmi-stereo>. I guess they are the two speakers of the computer? –  martina Jul 14 '13 at 19:02
    
Yeah sounds good. Also check what profile your internal card uses pacmd list-cards when speakers work, and when speakers dont work headphones work. This may give you additional hints on what might be the issue. (hard to debug remotely I am afraid) –  Takkat Jul 14 '13 at 19:15

I had a similar error once, what worked for me was editing the default.pa file, at /etc/pulse. Somehow, the first line was !/usr/bin/pulseaudio -nF, and instead of #!/usr/bin/pulseaudio -nF, so upon editing it, pulseaudio worked fine.

share|improve this answer
    
I have this first line commented (with the hashtag). Do you mean I should uncomment it? –  martina Jul 14 '13 at 13:05
    
no, it should be commented, the error i had was that there was no comment, so upon rectifying that, it was sorted –  Projjol Jul 14 '13 at 15:37
    
Well, I have it correctly commented. Uncommenting it has resulted in the audio icon up near the clock not working. –  martina Jul 14 '13 at 16:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.