Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am a new Ubuntu user and have installed Ubuntu 12.04 LTS on my Acer Aspire One D255 netbook with an Intel Centrino N1000 Wireless Card. All I want is to set my netbook as wifi hotspot for my android devices. This worked well for me in Windows 7 using Connectify but I am trying to make hotspot in Ubuntu using hostapd (http://nims11.wordpress.com/2012/04/27/hostapd-the-linux-way-to-create-virtual-wifi-access-point/comment-page-5/) but getting following error:

ali@ali-AOD255:~$ sudo hostapd ~/hostapd-test.conf
Configuration file: /home/ali/hostapd-test.conf
nl80211: Failed to set interface wlan0 into AP mode
nl80211 driver initialization failed.
ELOOP: remaining socket: sock=4 eloop_data=0x8178910 user_data=0x8178e80  handler=0x807c5e0
ELOOP: remaining socket: sock=6 eloop_data=0x817ac98 user_data=(nil) handler=0x8086770

All I want is to setup a wifi hotspot using my netbook so that my android devices can view and connect to it.

share|improve this question
    
Somebody please answer this ASAP :-( I too want to turn my 12.04, 32-bit Ubuntu Acer Aspire D270 Netbook, into a hotspot. –  Host-website-on-iPage Jul 15 '13 at 3:48
    
It looks nobody is gonna answer this... –  sixline Jul 16 '13 at 8:14
    
@sixline - Centrino processors are not easy ... - you could try it with Debian 7 - if it then is supported somehow ? - when booting to Debian-installation at start press 'Tab'-key - then add below in line boot-option: edd=off –  dschinn1001 Jul 16 '13 at 15:24
    
Does your card support master-mode & AP? Run following command:sudo apt-get install iw. Then run iw list. If there is 'AP' in the list of "Supported interface modes" your device will support the Access Point mode with hostapd. Then run sudo iwconfig wlan0 mode master. If you dont get a error then it supports master-mode & above steps (on the blog) will work. –  Khurshid Alam Jul 17 '13 at 0:08
    
@Khurshid: No there isn't any AP mode. –  sixline Jul 17 '13 at 13:21

2 Answers 2

up vote 4 down vote accepted
+50

To use your network card as wifi hotspot, it must support AP mode & master mode.

To check master-mode run:

sudo iwconfig wlan0 mode master. 

If you dont get a error then it supports master-mode

To check AP run following command:

sudo apt-get install iw

Then run:

iw list

If there is 'AP' in the list of "Supported interface modes" your device will support the Access Point mode with hostapd.

But as you commented above, that it doesn't support AP mode, The wifi hotspot wont work as explained in the blog.

Unlike windows, linux-kernel doesn't provide same features for every wireless cards.So for a particular wifi-card, windows driver may support AP , but linux-driver may not.

One option is to purchase a wireless card which supports AP modes. You can find more information here:

http://wireless.kernel.org/en/users/Drivers

Although according to me, the best option is to buy a USB Wifi-Router with 3G/Evdo modem support(preferably) like Lava W200 .

share|improve this answer
    
Well thanks for reply. I have a dual boot setup so I'll always switch back to Windows 7 to use connectify. That is real disapointment. –  sixline Jul 18 '13 at 12:11
    
Hopefully Linux-driver-stack will improve in future. If you are satisfied with the answer then you can mark the answer as accepted. –  Khurshid Alam Jul 19 '13 at 11:45
    
How to do that?? –  sixline Jul 20 '13 at 12:00
    
just click yes sign left of my answer.After that It will become green. See this answer as an example.Although you have to wait 48 hr to award bounty declared on it. –  Khurshid Alam Jul 20 '13 at 13:23
    
I am the one who offered the bounty. sixline can click only the 'tick' mark –  Host-website-on-iPage Jul 20 '13 at 17:39

Refer to the following link: http://www.webupd8.org/2013/06/how-to-set-up-wireless-hotspot-access.html

a simple and effective way to configure hotspot in most of the linux machines.

I have tried the hostapd way to configure wireless hotspot provided by Nims. Initially i had errors related to my configuration file(Read the comments of 'freekpeek' and 'Nipin Shakya', both are me) but finally it has worked too.

I had a BCM4312 802.11b/g LP-PHY router which didnt support Master Mode. The initial code provided would let you check your router's mode: mine initially showed the following:

winux@MagicBox:~$ lspci -k | grep -A 3 -i "network"
0c:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)
    Subsystem: Dell Wireless 1397 WLAN Mini-Card
    Kernel driver in use: wl
    Kernel modules: wl, ssb
winux@MagicBox:~$ 
winux@MagicBox:~$ modinfo wl | grep 'depend'
depends:        cfg80211,lib80211
winux@MagicBox:~$ 

Then i first tried to setup my router to act in master mode. You can check if your router is supported for master mode by referring to the following website: http://wireless.kernel.org/en/users/Drivers

Mine was Broadcom's. so, i checked my 'Chip ID' through the above website,and I clicked on the b43 from the list and did the following:

winux@MagicBox:~$ lspci -vnn -d 14e4:
0c:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01)
    Subsystem: Dell Wireless 1397 WLAN Mini-Card [1028:000c]
    Flags: bus master, fast devsel, latency 0, IRQ 17
    Memory at f6cfc000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: wl
    Kernel modules: wl, ssb

You can check yours too, matching your 'Chip ID' with the ones provided in the page above. If your router is supported for master mode, detailed step to downloading and installing the driver as suggested in each of the individual routers. You may then proceed with "INSTALLING HOSTAPD" topic from tutorial provided my NIMS.

Hope this helps. Regards, WinuxUser

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.