Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed lingot(guitar tuner- http://freshmeat.net/projects/lingot/) on Ubuntu but it doesn't seem to be detecting the sounds from the microphone. I'm using Ubuntu 10.10. Thanks

share|improve this question

1 Answer 1

Lingot's default sound input device is set to a raw Alsa input (e.g. plughw:0). In the Ubuntu desktop these inputs are opened in exclusive mode by PulseAudio, preventing other applications from opening them.

The solution is to make Lingot use the sound input device provided by PulseAudio, which is called pulse.

Either edit Lingot's configuration file $HOME/.lingot/lingot.conf and set

AUDIO_SYSTEM = ALSA
AUDIO_DEV_ALSA = pulse

or open Lingot's preferences window and set Audio System to ALSA and Audio Device to pulse.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.