Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

(Almost certain Wine is not to blame for this, unless I am unaware about a bug since 1.4 release) Uninstalled old Nvidia card, installed XFX Radeon HD 7850, tried to run a Steam (through Wine) game, outputs this:

Your graphics hardware does not support all features (CSM) needed to run this game.

Device Info:
Marked unsupported: 0
Supports PCF Sampling: 1
DriverName: "AMD Radeon HD 7800 Series"
Vendor ID: 0x1002, DeviceID: 0x6819
DriverHigh: 0x0006000E, DriverLow: 0x000A21E9
DXLevel: 95, MinDKSupportLevel: 90, MaxDXSupportLevel: 95

Has mildly laggy performance on desktop with full hinting, rgba antialiasing on a TV @ 1920x1080 resolution, haven't had much luck installing drivers as the jockey (or jockey-kde for 13.04) will only install drivers for "ATI FireGL" on it. Have reinstalled multiple times from the same install drive (USB) I've successfully installed on before and have also installed from on another build.

Have tried / gone through reconfiguring compiz, unity using dconf / --reset / --reset-icons, deleting 3.5.0 kernel so that the installscript downloaded directly from AMD for latest catalyst drivers uses 3.8.0 (just to make sure), purged xorg xserver-xorg fglrx* unity compiz ubuntu-desktop and reinstalled, reinstalled Wine multiple times, different versions, same problem (much of this was to get my Desktop display back without reinstalling).

Build description:

MSI 970A-g43
AMD Phenom II x6 1045t
PNY 8GB / 1333mhz, CAS 9
XFX Radeon HD 7850
400Watt PSU

About to upgrade PSU (honestly if that's the problem, I figured I would've seen many, many crashes by now or a melted PSU) to a 600Watt, can attempt (with a nice backup, something I'd rather not unless necessary) ANOTHER reinstallation (@12.04 + upgrade to 13.04, leave @ 12.04, new install drive @ 13.04) if just to see what happens.

Might have more information, depends if I can remember what all I've tried (lol). Would appreciate any help, have googled / tested for at least a month so far (on and off, inbetween work / everything else). Posted on Wine forums, but doubtful (since 12.04 jockey / 13.04 jockey-kde driver install shows "ATI FireGL" after installation).

Another odd detail: Minecraft performs about as well as it does on the other build, running an AMD a6-6400k on integrated graphics - around 60-80fps on max performance, fancy graphics, normal view distance, few other options all set to same (given cpu dependence and linux's low usage, maybe 2 cores @ 3.9 could perform as well as 6 @ 2.7? still seems illogical, and my Athlon x2 @ 3.0 with a Radeon HD 7850 performs slightly lower than both on Win7).

Can't really test graphics on HS 7850 build (that is, demanding graphics), and Nvidia card worked just fine on Steam.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.