Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My goal is to play Skyrim on my Ubuntu computer. I have already downloaded Wine, the Windows version of Steam and Skyrim. I have downloaded other games and they work just fine but not Skyrim.

I have noticed that the main difference between Skyrim and other games is that during the first start of the game there is a 'pop-up' that loads files for the first load of the game (this happens with all games). However with Skyrim there is a 3rd step where it tries to load something called microsoft.net this final step never loads and an error popup happens.

Could someone please help. I will be watching this thread closely and will respond promptly. Thank you.

additionally here is the program error details that it gives me:

Unhandled exception: 
unimplemented function msvcp90.dll.??0?$basic_ifstream@_WU?$char_traits@_W@std@@@std@@QAE@PB_WHH@Z called in 32-bit code (0x7b83ae0b).

Register dump: 
 CS:0023 SS:002b DS:002b ES:002b FS:0063 GS:006b
 EIP:7b83ae0b ESP:0033f770 EBP:0033f7d4 EFLAGS:00200246(   - --  I  Z- -P- )
 EAX:7b826449 EBX:7b8b0000 ECX:00000000 EDX:00139459
 ESI:00139459 EDI:00429ef0

Stack dump:
0x0033f770:  0033f7f4 00000008 7e335000 80000100 
0x0033f780:  00000001 00000000 7b83ae0b 00000002
0x0033f790:  7e2e29a0 7e2e5ff2 00000004 7e335000
0x0033f7a0:  0033f7e0 7e2dda88 0033f7bc 00403e52
0x0033f7b0:  00000001 00000000 00139e20 0033f7ec
0x0033f7c0:  00403059 0033fae8 b885c479 00139e20

=>0 0x7b83ae0b in kernel32 (+0x2ae0b) (0x0033f7d4)
  1 0x7e2e294d in msvcp90 (+0x4294c) (0x0033f804)
  2 0x7e2aca35 in msvcp90 (+0xca34) (0x0033fd08)
  3 0x0040a040 in skyrimlauncher (+0xa03f) (0x0033fd08)
  4 0x00412633 in skyrimlauncher (+0x12632) (0x0033fdb0)
  5 0x00407acf in skyrimlauncher (+0x7ace) (0x0033fe40)
  6 0x7b8621c8 call_process_entry+0xb() in kernel32 (0x0033fe58)
  7 0x7b86230e call_process_entry+0x151() in kernel32 (0x0033fea8)
  8 0x7bc7f84c call_thread_func_wrapper+0xb() in ntdll (0x0033feb8)
  9 0x7bc7f89b call_thread_func+0x44() in ntdll (0x0033ff98)
  10 0x7bc7f82a in ntdll (+0x6f829) (0x0033ffb8)
  11 0x7bc54b97 in ntdll (+0x44b96) (0x0033ffe8)
  12 0xf7607c19 wine_call_on_stack+0x1c() in libwine.so.1 (0x00000000)
  13 0xf7607bf7 wine_switch_to_stack+0x2a() in libwine.so.1 (0xfffa89d8)
  14 0x7bc54ed9 LdrInitializeThunk+0x341() in ntdll (0xfffa8a58)
  15 0x7b862be7 __wine_kernel_init+0x71b() in kernel32 (0xfffa98e8)
  16 0x7bc5566e __wine_process_init+0x156() in ntdll (0xfffa9938)
  17 0xf7606446 wine_init+0x13d() in libwine.so.1 (0xfffa9978)
  18 0x7bf011ca main+0x13d() in <wine-loader> (0xfffa9db8)
  19 0xf7431935 __libc_start_main+0xf4() in libc.so.6 (0x00000000)

0x7b83ae0b: subl    $4,%esp


Module  Address         Debug info  Name (93 modules)
PE    400000-  5d2000   Export          skyrimlauncher
PE  10000000-1009e000   Deferred        gameoverlayrenderer
PE  3b400000-3b41e000   Deferred        steam_api
ELF 7b800000-7ba44000   Dwarf           kernel32<elf>
  \-PE  7b810000-7ba44000   \               kernel32
ELF 7bc00000-7bce4000   Dwarf           ntdll<elf>
  \-PE  7bc10000-7bce4000   \               ntdll
ELF 7bf00000-7bf04000   Dwarf           <wine-loader>
ELF 7d3fb000-7d404000   Deferred        librt.so.1
ELF 7d404000-7d409000   Deferred        libgpg-error.so.0
ELF 7d409000-7d420000   Deferred        libresolv.so.2
ELF 7d420000-7d424000   Deferred        libkeyutils.so.1
ELF 7d424000-7d46e000   Deferred        libdbus-1.so.3
ELF 7d46e000-7d482000   Deferred        libp11-kit.so.0
ELF 7d482000-7d494000   Deferred        libtasn1.so.3
ELF 7d494000-7d518000   Deferred        libgcrypt.so.11
ELF 7d518000-7d521000   Deferred        libkrb5support.so.0
ELF 7d521000-7d526000   Deferred        libcom_err.so.2
ELF 7d526000-7d54e000   Deferred        libk5crypto.so.3
ELF 7d54e000-7d61c000   Deferred        libkrb5.so.3
ELF 7d61c000-7d62e000   Deferred        libavahi-client.so.3
ELF 7d62e000-7d63c000   Deferred        libavahi-common.so.3
ELF 7d63c000-7d701000   Deferred        libgnutls.so.26
ELF 7d701000-7d73e000   Deferred        libgssapi_krb5.so.2
ELF 7d73e000-7d79d000   Deferred        libcups.so.2
ELF 7d7a2000-7d7b5000   Deferred        gnome-keyring-pkcs11.so
ELF 7dc14000-7dc4b000   Deferred        uxtheme<elf>
  \-PE  7dc20000-7dc4b000   \               uxtheme
ELF 7dc4b000-7dc52000   Deferred        libxfixes.so.3
ELF 7dc52000-7dc5d000   Deferred        libxcursor.so.1
ELF 7dcbf000-7dce7000   Deferred        libexpat.so.1
ELF 7dce7000-7dd20000   Deferred        libfontconfig.so.1
ELF 7dd20000-7dd30000   Deferred        libxi.so.6
ELF 7dd30000-7dd34000   Deferred        libxcomposite.so.1
ELF 7dd34000-7dd3f000   Deferred        libxrandr.so.2
ELF 7dd3f000-7dd49000   Deferred        libxrender.so.1
ELF 7dd49000-7dd4f000   Deferred        libxxf86vm.so.1
ELF 7dd4f000-7dd53000   Deferred        libxinerama.so.1
ELF 7dd53000-7dd5a000   Deferred        libxdmcp.so.6
ELF 7dd5a000-7dd5e000   Deferred        libxau.so.6
ELF 7dd5e000-7dd80000   Deferred        libxcb.so.1
ELF 7dd80000-7dd86000   Deferred        libuuid.so.1
ELF 7dd86000-7dda0000   Deferred        libice.so.6
ELF 7dda0000-7ded7000   Deferred        libx11.so.6
ELF 7ded7000-7dee9000   Deferred        libxext.so.6
ELF 7dee9000-7def2000   Deferred        libsm.so.6
ELF 7def2000-7dfa3000   Deferred        winex11<elf>
  \-PE  7df00000-7dfa3000   \               winex11
ELF 7dfa3000-7dfbc000   Deferred        libz.so.1
ELF 7dfbc000-7e057000   Deferred        libfreetype.so.6
ELF 7e057000-7e07b000   Deferred        imm32<elf>
  \-PE  7e060000-7e07b000   \               imm32
ELF 7e07b000-7e0a7000   Deferred        msacm32<elf>
  \-PE  7e080000-7e0a7000   \               msacm32
ELF 7e0a7000-7e15d000   Deferred        winmm<elf>
  \-PE  7e0b0000-7e15d000   \               winmm
ELF 7e15d000-7e1aa000   Deferred        dsound<elf>
  \-PE  7e160000-7e1aa000   \               dsound
ELF 7e1aa000-7e1d9000   Deferred        msvcr90<elf>
  \-PE  7e1b0000-7e1d9000   \               msvcr90
ELF 7e1d9000-7e27b000   Deferred        msvcrt<elf>
  \-PE  7e1f0000-7e27b000   \               msvcrt
ELF 7e27b000-7e372000   Dwarf           msvcp90<elf>
  \-PE  7e2a0000-7e372000   \               msvcp90
ELF 7e372000-7e3fc000   Deferred        rpcrt4<elf>
  \-PE  7e380000-7e3fc000   \               rpcrt4
ELF 7e3fc000-7e55e000   Deferred        ole32<elf>
  \-PE  7e410000-7e55e000   \               ole32
ELF 7e55e000-7e67d000   Deferred        comctl32<elf>
  \-PE  7e570000-7e67d000   \               comctl32
ELF 7e67d000-7e698000   Deferred        version<elf>
  \-PE  7e680000-7e698000   \               version
ELF 7e698000-7e779000   Deferred        gdi32<elf>
  \-PE  7e6a0000-7e779000   \               gdi32
ELF 7e779000-7e8e9000   Deferred        user32<elf>
  \-PE  7e790000-7e8e9000   \               user32
ELF 7e8e9000-7e95f000   Deferred        shlwapi<elf>
  \-PE  7e900000-7e95f000   \               shlwapi
ELF 7e95f000-7eb9d000   Deferred        shell32<elf>
  \-PE  7e970000-7eb9d000   \               shell32
ELF 7eb9d000-7ec0f000   Deferred        advapi32<elf>
  \-PE  7ebb0000-7ec0f000   \               advapi32
ELF 7ec0f000-7ec1c000   Deferred        libnss_files.so.2
ELF 7ec1c000-7ec35000   Deferred        libnsl.so.1
ELF 7efbd000-7f000000   Deferred        libm.so.6
ELF f7413000-f7418000   Deferred        libdl.so.2
ELF f7418000-f75cb000   Dwarf           libc.so.6
ELF f75cc000-f75e7000   Deferred        libpthread.so.0
ELF f75e9000-f75f5000   Deferred        libnss_nis.so.2
ELF f75f5000-f75fe000   Deferred        libnss_compat.so.2
ELF f75ff000-f7743000   Dwarf           libwine.so.1
ELF f7745000-f7767000   Deferred        ld-linux.so.2
ELF f7767000-f7768000   Deferred        [vdso].so


process  tid      prio (all id:s are in hex)

0000000e services.exe
    0000001f    0
    0000001e    0
    00000015    0
    00000010    0
    0000000f    0

00000012 winedevice.exe
    0000001b    0
    00000018    0
    00000014    0
    00000013    0

00000019 plugplay.exe
    00000020    0
    0000001d    0
    0000001a    0

00000021 explorer.exe
    00000022    0

00000023 Steam.exe
    00000052    0
    00000051    0
    0000004e    0
    0000004b    0
    0000004a    0
    00000049    0
    00000048    0
    0000002e    0
    0000002d    0
    00000025    0
    00000026    0
    00000047    0
    0000003e    0
    00000009    0
    0000000b    0
    00000046    0
    00000045    0
    00000044    0
    00000043    0
    00000042    0
    00000041    0
    00000040    0
    0000003f    0
    0000003d    0
    0000003c    0
    0000003b    0
    0000003a    0
    00000039    0
    00000038    0
    00000037    0
    00000036    0
    00000035    0
    00000034    0
    00000033    0
    00000032    0
    00000031    0
    00000030    0
    0000002f    0
    0000002c    0
    00000029    0
    00000028    0
    00000024    0

00000065 (D) C:\Program Files (x86)\Steam\SteamApps\common\Skyrim\SkyrimLauncher.exe

    00000066    0 <==

System information:
    Wine build: wine-1.4.1
    Platform: i386 (WOW64)
    Host system: Linux
    Host version: 3.8.0-26-generic

If this helps at all

share|improve this question
I think you mean "Microsoft .NET". What's the error in the popup? –  Thomas W. Jul 14 '13 at 2:45
If the possibility of using Skyrim without Steam (Directly with Wine) exists then read askubuntu.com/questions/316025/… in my case I play Skyrim using Wine. It has worked since, well a long time ago: appdb.winehq.org/… –  Luis Alvarado Jul 14 '13 at 2:52
the error the pops up is :Program error, The program SkyrimLauncher.exe has encountered a serious problem and needs to close..." That is the error message that pops up. –  powell4076 Jul 14 '13 at 5:42
OK i will look at the post, so you are saying that you play Skyrim using wine only and no steam? Additionally did you download Skyrim from Steam or buy it else where. –  powell4076 Jul 14 '13 at 5:44
@powell4076 Actually it was bought as a gift for me in Amazon. Did not know it worked on Steam until you mentioned it here. If you followed the steps provided in the Wine guide and installed the latest version (with the components needed for Skyrim to work) then you should be fine. In the question I see you are still using wine 1.4 when the RC versions of 1.6 are already out using the PPA. –  Luis Alvarado Jul 14 '13 at 6:12

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.