Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use a custom compiled version of Wine and Minitube (no actual source changed, just compiled instead of installed from software centre), however for some reason their icons show up as grey question marks instead of the standard icon files. I'm pretty sure it's not an installation issue. I've attached my minitube installation log, if that's of any help:

gem@HAL9000:~/Downloads/minitube$ sudo make install
install -m 755 -p "build/target/minitube" "/usr/bin/minitube"
strip "/usr/bin/minitube"
cp -f -r /home/gem/Downloads/minitube/build/target/locale /usr/share/minitube/
install -m 644 -p /home/gem/Downloads/minitube/minitube.desktop /usr/share/applications/
install -m 644 -p /home/gem/Downloads/minitube/data/minitube.svg /usr/share/icons/hicolor/scalable/apps/
install -m 644 -p /home/gem/Downloads/minitube/data/16x16/minitube.png /usr/share/icons/hicolor/16x16/apps/
install -m 644 -p /home/gem/Downloads/minitube/data/22x22/minitube.png /usr/share/icons/hicolor/22x22/apps/
install -m 644 -p /home/gem/Downloads/minitube/data/32x32/minitube.png /usr/share/icons/hicolor/32x32/apps/
install -m 644 -p /home/gem/Downloads/minitube/data/48x48/minitube.png /usr/share/icons/hicolor/48x48/apps/
install -m 644 -p /home/gem/Downloads/minitube/data/64x64/minitube.png /usr/share/icons/hicolor/64x64/apps/
install -m 644 -p /home/gem/Downloads/minitube/data/128x128/minitube.png /usr/share/icons/hicolor/128x128/apps/
install -m 644 -p /home/gem/Downloads/minitube/data/256x256/minitube.png /usr/share/icons/hicolor/256x256/apps/
install -m 644 -p /home/gem/Downloads/minitube/data/512x512/minitube.png /usr/share/icons/hicolor/512x512/apps/

So, any idea what's going on and how can I fix it? Ubuntu 13.04, fresh install.

share|improve this question
    
Add the contents of /usr/share/minitube.desktop to your question please. –  edwin Jul 14 '13 at 0:29
    
Oops! I meant /usr/share/applications/minitube.desktop. Sorry. –  edwin Jul 14 '13 at 0:35
    
@edwin Done, added! –  Karoliina Jul 14 '13 at 0:39
    
Try setting the full icon path. Also make sure that /usr/share/icons/hicolor/scalable/apps/minitube.svg does exist and that you've rebooted. –  edwin Jul 14 '13 at 0:41
    
@edwin omg I love you! –  Karoliina Jul 14 '13 at 0:49
show 3 more comments

1 Answer

up vote 0 down vote accepted
gem@HAL9000:/usr/share/applications$ sudo vim minitube.desktop

And setting the line:

Icon=minitube

To:

Icon=/usr/share/icons/hicolor/scalable/apps/minitube.svg

Did the job perfectly!

Thanks @edwin !

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.