Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

Brand new to Ubuntu/Linux. Trying to get HP Mini netbook working better. It was unusable with Windows 7 (too slow).

So far it flies with Ubuntu, but no WiFi. I can see all the WiFi connections from my home, the neighbors, etc. I believe it connected briefly during installation, but I can't get it to connect now.

This is a clean install. The WiFi for all other home devices is working fine. Network specs are below. One of the moderators said it should work. The wired interface is working great, BTW.

Thank you in advance for your help

Machine is HP Mini 110. Ubuntu version is 13.04. Would I have better luck with 12.04?

01:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E 
  PCI Express Fast Ethernet controller [10ec:8136] (rev 04)
Subsystem: Hewlett-Packard Company Device [103c:148a]
Kernel driver in use: r8169

02:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless 
  LAN Controller [14e4:4727] (rev 01)
Subsystem: Hewlett-Packard Company Device [103c:145c]
Kernel driver in use: wl 
share|improve this question

marked as duplicate by Thomas W., Luis Jul 14 '13 at 3:36

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1  
Welcome to askubuntu! What do you mean by a moderator said...? –  edwin Jul 14 '13 at 0:23
    
Have you tried checking if your wifi is being either hard or soft-blocked by any chance? If not then type 'rfkill list all' –  matv1 Jul 14 '13 at 1:44
    
Sorry, copied from another forum that had a response from a moderator. This worked, by the way: sudo apt-get purge bcmwl-kernel-source sudo modprobe brcmsmac –  buzz999 Jul 15 '13 at 4:17

1 Answer 1

This should get your wireless working.

sudo apt-get purge bcmwl-kernel-source

sudo modprobe brcmsmac
share|improve this answer
    
This answer is specific to 13.04. –  Wild Man Jul 14 '13 at 5:22
    
Thank you Wild Man, that worked!!! –  buzz999 Jul 15 '13 at 4:18

Not the answer you're looking for? Browse other questions tagged or ask your own question.