Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Since the usability gods work in mysterious ways, in 13.04 it's no longer possible to whitelist systray icons that I want to see. While the messaging menu is less useful than the flashing Pidgin icon (since I can't configure it to flash), it seems I'll have to make do with it.

So I managed to get Pidgin to integrate with that by enabling the libnotify-plugin in Pidgin. However, that leaves me with another problem: How can I have this work (i.e. trigger the messaging menu icon and integrate with that menu) without it actually showing popups for each of those events? At work, I'm often showing coworkers things on my machine, and it is extremely distracting to have these popups show up all the time, not to mention sometimes a privacy issue. Yet when I turn them off, I get no notification whatsoever.

What can I do?

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

Tools/Plugins/libnotify/Configure Plugin, then you can uncheck all the events that trigger notifications. They aren't used for the Messaging Menu portion of the plugin.

share|improve this answer
    
I... well that's odd. I tried that, and I was positive that it didn't work - I was getting messages without them showing up in the indicator/messaging menu. I just tried it again, and it appears to be working now. Bizarre. Maybe it only works for newly opened windows? In any case, thanks! –  Carl-Eric Menzel Jul 13 '13 at 23:52
    
There is a bug where it sometimes loses the first message which I haven't been able to track down, that may have been what you experienced. –  Jason Conti Jul 14 '13 at 0:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.