Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I wish to compile vim7.3 with python-interp enabled, which requires python-dev package.

The problem is I have python-2.6.6-2ubuntu2 while python-dev requires python-2.6.6-2ubuntu1. (I don't how i got it. http://pastie.org/1706980)

So, I have decided to downgrade python to -2ubuntu1. But, apt-get puts another error message -

Reading package lists... Done Building dependency tree
Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies:
python : Depends: python-minimal (= 2.6.6-2ubuntu1) but 2.6.6-2ubuntu2 is to be installed
E: Broken packages

So, how do i resolve this? Downgrade python-minimal first?
Many packages will be removed then.

Also, sudo aptitude install python=2.6.6-2ubuntu1 outputs this. Telling me to remove quite a few things.
I am not sure this is the right way.

p.s. Google didn't help much.


[solved]

Installing python-dev from maverick-updates worked.

share|improve this question

1 Answer 1

up vote 4 down vote accepted

Just install the right python-dev (2.6.6-2ubuntu2) from maverick-updates.

share|improve this answer
    
how different is maverick-updates from main? –  N 1.1 Mar 25 '11 at 13:26
    
This repository delivers recommended updates for Maverics. You can enable it by selecting Updates > Recommended Updates in the Update Manager. –  Adam Byrtek Mar 25 '11 at 14:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.