Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.
mount: mounting /sys on /root/sys failed: No such file or directory
mount: mounting /dev on /root/dev failed: No such file or directory
mount: mounting /sys on /root/sys failed: No such file or directory
mount: mounting /proc on /root/proc failed: No such file or directory
Target file system doesn't have /sbin/init
No init found. Try passing init= bootarg

Busybox v1.13.3 (Ubuntu 1:1.13.3-1ubuntu7) built-in shell (ash)
Enter 'help' for a list of built-in commands
(initramfs) _

I tried passing init=bootarg in linux by editing the boot option in grub but it doesn't help.. I tried to boot the live cd trying to get my files but as I mount the volume it goes forever...how should I fix this?

edit: I tried using fsck but it says,

filesystem mounted or opened exclusively by other program?
fsck: Device or resource busy while trying to open /dev/sda1

Are there any low level system utilities for linux that can be booted (a little similar to msdos' command.com ) so that I will use fsck under it to make sure that the device is not busy or in use?

share|improve this question

3 Answers 3

Boot into the LiveCD again, launch GParted, and check the partition (click on the partition and choose Partition → Check). If you see any errors, save them and copy them here.

share|improve this answer
    
it says: Device or resource is busy.. I tried using fsck..but same result.. –  prinzrainer Mar 27 '11 at 5:45
    
Is the partition really unmounted (see output of mount)? Are you using a LiveCD or LiveUSB? Which version of Ubuntu? BTW I think busybox (see your original post and the prompt) supports basic commands like mount, umount and fsck. –  arrange Mar 27 '11 at 15:14
    
filesystem is not mounted...I'm using a LiveCD (ubuntu 10.10)... I tried mounting it w/ busybox..but still same as I do it on ubuntu terminal...Mount executes but never returns... Fortunately I can still use debugfs to backup my important files but I still want my old system back... –  prinzrainer Mar 28 '11 at 7:06
    
I just don't understand why I can't be mounted while debugfs can still open it..Also,, isn't the '/' (root dir) used when the booting stopped, is still the root of the disk image loaded by initrd?? So /sbin/init is still from the disk image. Could it be that the disk image is damaged? –  prinzrainer Mar 28 '11 at 7:18
    
Have you tried fscking the partition from the busybox prompt? –  arrange Mar 28 '11 at 8:22

You need check the filesystem on the Hard Disk Drive.

  1. Run LiveCD, open terminal
  2. In terminal, type

    sudo fdisk -l
    

    This command display your partitions

  3. Then

    sudo fsck.ext4 -f /dev/partition_on_disk
    

    for example

    sudo fsck.ext4 -f /dev/sda2
    
  4. On every fix? answer y.

  5. Reboot system

Source here

share|improve this answer

I was a victim of "Target filesystem doesn't have /sbin/init". I tried using fsck, but it didn't work because of the following problem. 

fsck: Device or resource busy while trying to open /dev/sda1 Filesystem mounted or opened exclusively by another program?

So here is the solution:

Boot from Live Ubuntu CD.

->remove the first inode.

sudo debugfs -w /dev/sda1
debugfs 1.41.11 (14-Mar-2010)
debugfs: clri <8>
debugfs: quit

->Restart into live cd again. and do

sudo fsck -yv /dev/sda1

It will work this time. 

Cheers

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.