Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

First off all, I want to say that I'm not new to Ubuntu, and I primarily use it as a gateway server. I have Ubuntu 12.04 LTS server without a GUI.

These days after a big storm, I had a power outage. When the power came back, everything was OK, until I spotted the problem.

root@ubuntu:~# uname -a
Linux ubuntu 3.2.0-49-generic-pae #75-Ubuntu SMP Tue Jun 18 18:00:21 UTC 2013 i686 i686 i386 GNU/Linux

This is the problem:

root@ubuntu:~# nslookup google.com
Server: 192.168.1.254
Address: 192.168.1.254#53
Name: google.com
Address: 198.18.1.13

root@ubuntu:~# nslookup yahoo.com
Server: 192.168.1.254
Address: 192.168.1.254#53
Name: yahoo.com
Address: 198.18.1.14

root@ubuntu:~# nslookup ubuntu.com
Server: 192.168.1.254
Address: 192.168.1.254#53
Name: ubuntu.com
Address: 198.18.1.24

The problem is that even the PHP functions file_get_contents or gethostbyname are not working, and they give me the same IP class on query.

Other effects:

root@ubuntu:~# ping google.com
PING google.com (198.18.1.13) 56(84) bytes of data.
^C
--- google.com ping statistics ---
23 packets transmitted, 0 received, 100% packet loss, time 22173ms  

root@ubuntu:~# apt-get update
0% 
[Connecting to it.archive.ubuntu.com (198.18.1.19)] 
[Connecting to security.ubuntu.com (198.18.1.18)] 
[Connecting to archive.canonical.com (198.18.1.17)] 
[Connecting to ppa.launchpad.net (198.18.1.16
...
...
W: Failed to fetch http://it.archive.ubuntu.com/ubuntu/dists/precise-backports/universe/i18n/Translation-en  
Unable to connect to it.archive.ubuntu.com:http:
E: Some index files failed to download. They have been ignored, or old ones used instead.

My network configuration is like this:

internet--adsl router--ubuntu gw--switch lan/wifi--computers  

adsl router has a pppoe connection with the provider and it has the ip 192.168.1.254

Ubuntu has the following output from running ifconfig and route -n:

root@ubuntu:~# ifconfig

eth0      Link encap:Ethernet  HWaddr 00:10:b5:f9:d4:76
          inet addr:192.168.1.2  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::210:b5ff:fef9:d476/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:540782 errors:0 dropped:0 overruns:0 frame:0
          TX packets:327646 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:731616835 (731.6 MB)  TX bytes:26098933 (26.0 MB)
          Interrupt:17 Base address:0x3000**

eth1      Link encap:Ethernet  HWaddr 00:e0:4c:3a:5d:a2
          inet addr:192.168.0.3  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::2e0:4cff:fe3a:5da2/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:313887 errors:0 dropped:0 overruns:0 frame:0
          TX packets:526813 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:25127774 (25.1 MB)  TX bytes:730199162 (730.1 MB)
          Interrupt:18 Base address:0x3400**

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:728 errors:0 dropped:0 overruns:0 frame:0
          TX packets:728 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:41363 (41.3 KB)  TX bytes:41363 (41.3 KB)

root@ubuntu:~# route -n

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.254   0.0.0.0         UG    100    0        0 eth0
192.168.0.0     0.0.0.0         255.255.255.0   U     0      0        0 eth1
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0

Needless to say that in my LAN all is going well, for example:

C:\Users\Leon>ping google.com
Pinging google.com [74.125.232.136] with 32 bytes of data:
Reply from 74.125.232.136: bytes=32 time=27ms TTL=53
Reply from 74.125.232.136: bytes=32 time=25ms TTL=53
Reply from 74.125.232.136: bytes=32 time=28ms TTL=53
Reply from 74.125.232.136: bytes=32 time=24ms TTL=53
Ping statistics for 74.125.232.136:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 24ms, Maximum = 28ms, Average = 26ms

So this is the problem. It may be from the last update taken 2-3 days back, and I spotted the problem only after the power outage, or it may be from the power outage, even though I doubt it, because with ext4 and jbd2 I feel somewhat protected against data loss.

Thank you for your answers. I will try to post asap if you have any more questions.

share|improve this question
add comment

1 Answer 1

After the problem persisted, and no answer from the askubuntu comunity, today i have maked a little time to try to fix the problem....

I have recreated all the bind configurations, at no effect, well some effect yes, but no one to repair the error ....

At the end it has been clear that the problem is in bind... so i have find the error in the end:

the file is

/etc/default/bind9

i edited and in him i have found that i have:

# run resolvconf?
RESOLVCONF=no

# startup options for the server
OPTIONS="-u bind"

edited so i could have:

 RESOLVCONF=yes

and now all it's going as expected from the server...

p.s. if someone know how could from a power loss to have an effect like this, be my quest :). And if you look in that file, could you tell me what is the default value you are having? Thank you

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.