Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am new user for Ubuntu. I have updated my OS from Ubuntu 12.04 to (12.10 and now) 13.04. I have a DVD of movies, which works fine in Windows 7, and I am able play the movies, and can see the contents. But when I try that DVD in my Ubuntu, I am getting Blank "DVD-R disk" under device, and when I click on it, it just displays option to burn the disk, not displaying the content, I am not able to see the movies which are there in DVD. Help me resolve the issue

Blank CD/DVD drive image

share|improve this question

3 Answers 3

This is a complete reinstall:

sudo add-apt-repository ppa:ferramroberto/vlc
sudo apt-get update
sudo apt-get -y install w32codecs ubuntu-restricted-codecs 
sudo apt-get -y vlc mozilla-plugin-vlc
sudo apt-get -y install libdvdcss2 libdvdnav4 libdvdread4
sudo sh /usr/share/doc/libdvdread4/install-css.sh
sudo apt-get -y install regionset
sudo regionset
rm -R ~/.dvdcss/

Please read Linux Set DVD Region Code. You may also have to reboot...

Please refer also to these other similar questions:

For your information, as explained on Wikipedia article about libdvdcss, Ubuntu does not provide libdvdcss to respect Digital Millennium Copyright Act.

share|improve this answer
    
I have tried this, but still it doesn't work... :( –  Surendhar Jul 12 '13 at 15:57
    
I have added more stuff to install in my answer. Please try what I have added. Have you read the other answers? Have you Have you rebooted? Do you have an error message? dmsg? What is the title of your DVD? Does your DVD embeds DRM protection? (it should be mentioned somewhere on the DVD) Is your DVD reader able to read any other DVD? (using Ubuntu 13.04) –  olibre Jul 12 '13 at 16:09
    
I have tried everything what you have suggested, but still it shows me like "Blank DVD-R disk". when I click on it, the title something like "Data disc (12 Jul 13)". –  Surendhar Jul 12 '13 at 16:19
    
I have again competed my answer, please redo all the steps. Please, check your DVD reader using others DVDs: maybe your DVD reader (driver) is not (yet) functional on Ubuntu 13.04... –  olibre Jul 12 '13 at 16:22

This is what worked for me:

sudo apt-get install gstreamer0.10-plugins-ugly gstreamer0.10-ffmpeg libxine1-ffmpeg gxine mencoder libdvdread4 totem-mozilla icedax tagtool easytag id3tool lame nautilus-script-audio-convert libmad0 mpg321

sudo /usr/share/doc/libdvdread4/install-css.sh

sources: http://www.itworld.com/software/354185/enable-dvd-playback-and-install-multimedia-codecs-ubuntu-1304

http://www.noobslab.com/2013/04/tweaksthings-to-do-after-install-of.html

share|improve this answer

I have the same blank disk problem on self burned data dvd disks, but noticed, that I can see the files in it if remounting manually, by doing:

umount /dev/sr0
sudo mount /dev/sr0 /home/krister/disk

Afterwards Ubuntu automatic mounting works too for this dvd only, but I haven't checked if this retains over reboot.

  • Could you guys fix this, please?
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.