Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been trying to install ubuntu (server edition, 13.04 i386) through a USB pen drive, and so far I've miserably failed. This is on a lenovo x230, with USB-* options all up there in the boot order, as well as UEFI / secureboot support disabled (as it seems it messes with most linux distro). So far I've tried this (on my old ubuntu 10.04, and sometimes, purely out of boredom, on win 7) :

  • The native usb-creator-gtk proving to be useless (i.e. crashed), I've instead opted with unetbootin. Invariably, it only gives me a "Boot error" message when plugged in, and nothing more. I've been careful to always format the usb drive first (FAT), through the graphical tool or some other console tool (msdostk... mtkdos... something along those lines) and shoot a "sync" as well as a "eject /dev/sdX" afterwards.

  • Copying directly the iso : using "cat", "cp" or "dd" directly into the pen drive. Most of the time, it would simply not boot. A few days ago I was trying my hand at installing debian, and this is the only thing I've tried that actually worked, was to copy directly the netinstall image on the pen drive. Unfortunately I've had problems with that installation which are outside the scope of this post.

  • As I was writing this, I was also trying out some other tool, Universal USB Installer (win 7, with the same iso as before). And lo and behold, the god forsaken pen drive did boot. Only problem is it's in rescue mode (maybe ubuntu is recognizing the existing debian installation?) and even then, is insisting on mount the cd-rom drive (which is inexistent). Great.

So at this point I'm thinking it might have something to do with the pen drive itself (although it is able to boot, albeit once in a goddamn blue moon) or the laptop settings.

share|improve this question

migrated from unix.stackexchange.com Jul 11 '13 at 21:21

This question came from our site for users of Linux, FreeBSD and other Un*x-like operating systems..

1 Answer 1

See my answer to this U&L Q&A titled: Run CentOS 6 from a USB flash drive. There is an application that you can use called unetbootin which can assist in the creation of the USB boot media. I've used in dozens of times and it works flawlessly.

          ss of unetbootin

share|improve this answer
    
Yes I did use unetbootin quite a bit, under ubuntu and win 7. And for a few different iso. I did hear good things about it, but for me, it never did work correctly. –  Afrosimon Jul 9 '13 at 22:12
    
@Afrosimon - sorry to hear that. I recall a while ago having a USB thumbdrive that I could never get to work consistently either. I ended up abandoning it and haven't experienced any similar issues since that one device. Have you attempted to run a diagnostic tool such as HDAT or Spinrite on the thumbdrive? Or even windows chkdsk? I would be suspicious of it at this point. –  slm Jul 9 '13 at 22:14
2  
Yeah I was wondering about that too. I've run the diagnostic tool in win 7, and it did find some "inconsistencies" so right now I'm assuming the pen drive was the problem. I shall prepare a pyre to erase its existence from this cruel world, and buy a new one. –  Afrosimon Jul 9 '13 at 22:29
    
I've had terrible luck using unetbootin and Ubuntu to create a bootable USB. On the other hand, I've found dd if=ubuntu_image.iso of=/dev/sdb where if is this input file, the .iso, and of is the output file, the device that is your USB drive to be made bootable. Make sure you get those right, 'cause dd has a nickname: disk destroyer! It will overwite things if you point it at the wrong destination. –  Marc Jul 11 '13 at 22:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.