Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an Intel graphics card

on

3.5.0-36-generic #57~precise1-Ubuntu SMP Thu Jun 20 18:21:09 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

 lspci-nnk | grep-i VGA-A2

 00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09)
 Subsystem: Hewlett-Packard Company Device [103c: 1858]
 Kernel driver in use: i915
  1. What a PAA I need to take so that I have full power so I can play with Steam?

    Will Steam install to Softwarecenter

    Steam needs to install these additional packages:
    libgl1-mesa-dri-lts-quantal:i386, libgl1-mesa-glx-lts-quantal:i386, libc6:i386

    /usr/lib/nux/unity_support_test -p  
    
     Intel Open Source Technology Center
     OpenGL renderer string: Mesa DRI Intel (R) Sandy Bridge Mobile
     OpenGL version string: 3.0 Mesa 9.0.3
    
     Not software rendered: yes
     Not blacklisted: yes
     GLX fbconfig yes
     GLX texture from pixmap: yes
     GL npot or rect textures: yes
     GL vertex program: yes
     GL fragment program: yes
     GL vertex buffer object: yes
     GL framebuffer object: yes
     GL version is 1.4 +: yes
    
     Unity 3D supported: yes
    
  2. And what / entries Should Be in my /etc/X11/xorg.conf:

    Section "Screen"
    Section "Device"
    
  3. cat /proc/cmdline

    BOOT_IMAGE=/boot/vmlinuz-3.5.0-36-generic root=UUID=d49f068f-52ac-47ed-8a03-71b7a69884f6 ro quiet splash vt.handoff=7
  4. dmesg | grep i915

    [    1.155970] i915 0000:00:02.0: setting latency timer to 64
    [    1.191712] i915 0000:00:02.0: irq 43 for MSI/MSI-X
    [    1.870345] [drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0
    [ 5385.318716] i915 0000:00:02.0: setting latency timer to 64
    [18434.366480] i915 0000:00:02.0: setting latency timer to 64
    [23459.306806] i915 0000:00:02.0: setting latency timer to 64
    [24639.875228] i915 0000:00:02.0: setting latency timer to 64
  5. glxgears screenshot: http://screencloud.net/v/9FM4.

    Running synchronized to the vertical refresh. The framerate should be approximately the same as the monitor refresh rate.

    296 frames in 5.0 seconds = 59.110 FPS
    300 frames in 5.0 seconds = 59.912 FPS
    300 frames in 5.0 seconds = 59.902 FPS
    300 frames in 5.0 seconds = 59.900 FPS
    300 frames in 5.0 seconds = 59.904 FPS

  6. xrandr --prop.

Blockquote Screen 0: minimum 320 x 200, current 1366 x 768, maximum 8192 x 8192 LVDS1 connected 1366x768+0+0 (normal left inverted right x axis y axis) 344mm x 194mm EDID: 00ffffffffffff0030e4840300000000 00160104902213780a01a59c595a9b26 18505400000001010101010101010101 010101010101d81d56f4500016302430 350058c21000001be51356f450001630 2430350058c21000001b000000000000 00000000000000000000000000000002 000c47ff0a3c6412222964000000007f BACKLIGHT: 6 (0x00000006) range: (0,10) Backlight: 6 (0x00000006) range: (0,10) scaling mode: Full aspect supported: None Full Center Full aspect 1366x768 60.1*+ 40.0 1360x768 59.8 60.0
1024x768 60.0 800x600 60.3 56.2 640x480
59.9 VGA1 disconnected (normal left inverted right x axis y axis) HDMI1 disconnected (normal left inverted right x axis y axis) Broadcast RGB: Full supported: Full Limited 16:2 audio: auto supported: force-dvi off auto on
DP1 disconnected (normal left inverted right x axis y axis) Broadcast RGB: Full supported: Full Limited 16:2 audio: auto supported: force-dvi off auto on

7.) /etc/default/grub

GRUB_DEFAULT=0 GRUB_HIDDEN_TIMEOUT=0 GRUB_HIDDEN_TIMEOUT_QUIET=true GRUB_TIMEOUT=10 GRUB_DISTRIBUTOR=lsb_release -i -s 2> /dev/null || echo Debian GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" GRUB_CMDLINE_LINUX=""

Currently have the PAA # ppa:ubuntu-x-swat/x-updates sudo add-apt-repository ppa:ubuntu-x-swat/x-updates && sudo apt-get update -y

I have the following problem

What should be in the xorg.conf? What should be in the / etc / default / grub?

at the moment it shows me under this Serious Sam 3 BFE http://screencloud.net/v/EX1g and is Non Playable and jerky

sudo lshw -c video
  *-display               
       Beschreibung: VGA compatible controller
       Produkt: 2nd Generation Core Processor Family Integrated Graphics Controller
       Hersteller: Intel Corporation
       Physische ID: 2
       Bus-Informationen: pci@0000:00:02.0
       Version: 09
       Breite: 64 bits
       Takt: 33MHz
       Fähigkeiten: msi pm vga_controller bus_master cap_list rom
       Konfiguration: driver=i915 latency=0
       Ressourcen: irq:42 memory:c2000000-c23fffff memory:b0000000-bfffffff ioport:4000(Größe=64)
hwinfo --gfxcard
> hal.1: read hal dataprocess 12471: arguments to dbus_move_error() were incorrect, assertion "(dest) == NULL ||

!dbus_error_is_set ((dest))" failed in file ../../dbus/dbus-errors.c line 282. This is normally a bug in some application using the D-Bus library. libhal.c 3483 : Error unsubscribing to signals, error=The name org.freedesktop.Hal was not provided by any .service files 08: PCI 02.0: 0300 VGA compatible controller (VGA)
[Created at pci.318] Unique ID: _Znp.nDJOnrrEzD7 SysFS ID: /devices/pci0000:00/0000:00:02.0 SysFS BusID: 0000:00:02.0 Hardware Class: graphics card Model: "Intel VGA compatible controller" Vendor: pci 0x8086 "Intel Corporation" Device: pci 0x0116 SubVendor: pci 0x103c "Hewlett-Packard Company" SubDevice: pci 0x1858 Revision: 0x09 Driver: "i915" Driver Modules: "drm" Memory Range: 0xc2000000-0xc23fffff (rw,non-prefetchable) Memory Range: 0xb0000000-0xbfffffff (ro,non-prefetchable) I/O Ports: 0x4000-0x403f (rw) IRQ: 42 (100414 events) Module Alias: "pci:v00008086d00000116sv0000103Csd00001858bc03sc00i00" Driver Info #0: Driver Status: i915 is active Driver Activation Cmd: "modprobe i915" Config Status: cfg=new, avail=yes, need=no, active=unknown

Primary display adapter: #8
share|improve this question
add comment

1 Answer

Intel HD 2000 Graphics driver is open source, and you don't need to install anything.

But possible to improve performance, leave xorg Settings automatic.

Use the latest version of Linux kernel and mesa

And keep the CPU GOVERNOR "performance" (You can do that in Ubuntu by installing indicator-cpufreq and run it from terminal: indicator-cpufreq , You will see the program icon in the panel)

share|improve this answer
    
Thank you for the answer it really helped :-) –  Tuxplayer Oct 28 '13 at 12:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.