Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I upgraded to 11.04 using update-manager -d. When I try to boot, I just get a purple blank screen, with no ubuntu logo/dots showing. It never gets to the gdm login screen (I left it for 20min) and I can't get to a tty by pressing Ctrl+Alt+F1. I don't see a grub menu/count down screen either.

My computer is a Dell Vostro 1500 with a Nvidia Geforce. I had the proprietary nvidia driver installed before upgrading.

I've boot with a live cd, from where I am writing this, and I can mount the disk, but I don't know where to start looking for the issue.

share|improve this question

marked as duplicate by belacq, Luis Alvarado Aug 4 at 22:26

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
11.04 is currently Alpha so things might not work right. Please see askubuntu.com/questions/18641/… and meta.askubuntu.com/questions/871/… for better instructions on how to proceed. –  Jorge Castro Mar 24 '11 at 18:58

4 Answers 4

I tried booting again, and was able to get into the grub menu. Not sure why I could not get to the menu before. Maybe I just was not pressing the down arrow soon enough. (The grub menu is now also purple.)

I can boot with an old kernel 2.6.35-28-generic, but not with the new kernel 2.6.38.7. This corresponds with the note about nvidia drivers it the release notes.

share|improve this answer

i had this issue too and i solved it installing the appropriate version of nvidia drivers (for me 173.xx) simply log in with a ubuntu classic (no effects) session, go to administration -> proprietary driver and you'll find you have a recommended version of nvidia drivers installed and another one. just activate the other one and reboot. cheers karma

share|improve this answer

What I did from the command line is to find the packages for nvidia (dpkg -l | grep nvidia) and then apt-get remove nvidia-173 (or whatever package you get from the previous command).

The problem is that you will still have the nvidia modues listed in xorg.conf. So, I also mv /etc/X11/xorg.conf /etc/X11/xorg.conf_backup and rebooted.

I landed in a graphical mode as usual, without the nvidia GL stuff, but then there are graphical tools to set it up.

At this state, it's safe to delete the xorg.conf backup you just created.

share|improve this answer

You can try the Noveau drivers for NVIDIA or try this:

sudo gedit /etc/default/grub

Look for the quiet nosplash section and add this next to it: nohz=off

Then:

sudo update-grub

I had a similar problem with an ATI/AMD card and didn't want to use the pci=noacpi since it disables key features.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.