Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 12.04 LTS.

Some months ago I installed Amnesia - The Dark Descent which uses 3D graphics and therefore refused to run using Nouveau. So, after having no luck using the Additional Drivers application, I downloaded the appropriate NVIDIA driver (NVIDIA-Linux-x86_64-310.32.run) from the NVIDIA website. I installed the driver with a little help from this page:

How to install NVIDIA.run?

However, the screen resolution was far too low. I tried quite a few different solutions I found online involving xrandr and xorg.conf but they had no effect. In the end I removed xorg.conf which fixed the resolution problem but Amnesia still didn't work and all my other games that previously worked fine would not even start up. Plus whenever I logged into Ubuntu the screen would flash grey for two seconds, which it didn't do before, and the Unity toolbar scrolls down instead of having the extra icons bunched together at the bottom.

So I gave up and left it as it was for a while and eventually I downloaded an update that somehow restored things to the way they were before (games worked again, Unity toolbar was back to normal and no more grey flash).

Later I tried again with a slightly more up to date NVIDIA driver (NVIDIA-Linux-x86_64-319.23.run), still with no success and with the same problems as before. I tried a few more solutions but ultimately decided that the NVIDIA driver is more trouble than it's worth (I'll have to download the Windows version of Amnesia), so I tried to completely remove it and restore Nouveau using this method:

How can I uninstall a nvidia driver completely ?

This still had no effect. Now, when I type

dpkg -l | grep -i nvidia

nvidia-common is all that's left but the games still won't run (BIT.TRIP BEAT throws up a message saying "Fatal Error - failed to create SDL window: Couldn't find matching GLX visual" but the rest do nothing when I click on the icons), the screen still flashes grey on login and I still have to scroll down the Unity bar.

So, how can I get my games up and running again? Does anyone know what the update was that fixed things before (there were A LOT of updates at the time) and how I can re-install that update? Are there still other NVIDIA files I need to remove?

Thank you for your time.

-- Richard

share|improve this question
add comment

2 Answers 2

Try reinstalling the Nvidia drivers completely:

sudo apt-get purge nvidia*
sudo apt-get install nvidia-current
share|improve this answer
    
Nope. I tried that and it didn't change anything. I entered 'sudo apt-get install --reinstall ubuntu-desktop' after because it also uninstalled ubuntu-desktop. I'd prefer to get rid of the Nvidia driver and just use Nouveau because when I used that before most things worked fine. –  Richard Jul 13 '13 at 16:07
add comment
up vote 0 down vote accepted

SOLVED

Thanks to Bruno Pereira in this thread:

Switch from NVidia to internal Intel HD graphics - OpenGL does not work

I needed to completely re-install and re-configure Xorg using the following:

sudo apt-get install --reinstall xserver-xorg-core libgl1-mesa-glx:i386 libgl1-mesa-dri:i386 libgl1-mesa-glx:amd64 libgl1-mesa-dri:amd64

then

sudo dpkg-reconfigure xserver-xorg

then reboot

sudo reboot

And now everything has been returned to normal.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.