Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I tried to fix one problem and created another...

My update manager broke...

The package system is broken

Check if you are using third party repositories. If so disable them, since they are a common source of problems. Furthermore run the following command in a Terminal: apt-get install -f

I run apt-get install -f and I get:

missx@missx:~$ apt-get install -f
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

I tried reinstalling software center i get this

missx@missx:~$ sudo apt-get --reinstall install software-center
[sudo] password for missx: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 network-manager-dbg : Depends: network-manager (= 0.9.4.0-0ubuntu3) but 0.9.4.0-0ubuntu4.2 is to be installed or
                                libnm-util2 (= 0.9.4.0-0ubuntu3) but 0.9.4.0-0ubuntu4.2 is to be installed or
                                libnm-glib4 (= 0.9.4.0-0ubuntu3) but 0.9.4.0-0ubuntu4.2 is to be installed or
                                libnm-glib-vpn1 (= 0.9.4.0-0ubuntu3) but 0.9.4.0-0ubuntu4.2 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

The network maneger is the piece of crap I installed yesterday to fix my wi-fi issue...

Don't have synaptic installed (that would be too easy, right..?)

sudo apt-get -f install

missx@missx:~$ sudo apt-get -f install 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  linux-headers-3.2.0-38 libsub-name-perl libparse-debianchangelog-perl
  libnspr4-0d:i386 libsigc++-2.0-0c2a:i386 libcwidget3
  libboost-iostreams1.46.1 libgconf2-4:i386 libapt-pkg4.12:i386
  libio-string-perl linux-headers-3.2.0-38-generic libept1.4.12
  libclass-accessor-perl libnss3-1d:i386
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  network-manager-dbg
The following packages will be upgraded:
  network-manager-dbg
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 0 B/1,463 kB of archives.
After this operation, 8,192 B of additional disk space will be used.
Do you want to continue [Y/n]? y
dpkg: dependency problems prevent configuration of network-manager-dbg:
 network-manager-dbg depends on network-manager (= 0.9.4.0-0ubuntu3) | libnm-util2 (= 0.9.4.0-0ubuntu3) | libnm-glib4 (= 0.9.4.0-0ubuntu3) | libnm-glib-vpn1 (= 0.9.4.0-0ubuntu3); however:
  Version of network-manager on system is 0.9.4.0-0ubuntu4.2.
  Version of libnm-util2 on system is 0.9.4.0-0ubuntu4.2.
  Version of libnm-glib4 on system is 0.9.4.0-0ubuntu4.2.
  Version of libnm-glib-vpn1 on system is 0.9.4.0-0ubuntu4.2.
dpkg: error processing network-manager-dbg (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                      Errors were encountered while processing:

network-manager-dbg E: Sub-process /usr/bin/dpkg returned an error code (1)"

share|improve this question

marked as duplicate by Radu Rădeanu, Luis Alvarado Jul 11 '13 at 13:43

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
you miss typed the command. You missed an 'l' out the command is sudo apt-get install -f –  Warren Hill Jul 11 '13 at 14:48
    
Just do sudo apt-get remove network-manager-dbg and you will get rid of the error. –  Braiam Sep 9 '13 at 13:34

1 Answer 1

I see no reason to reinstall software center.

The "apt-get install" command needs "sudo" in front of it.

As you can see from the error message E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied) E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

I don't know what your wireless issue was, but I don't see why installing network manager would have fixed it (considering network manager is installed by default and from the messages you posted, I'm guessing you just upgraded it)

share|improve this answer
    
missx@missx:~$ sudo apt-get -f instal [sudo] password for missx: E: Invalid operation instal –  Shellby Jul 11 '13 at 14:15
    
@Shellby You typo'd install. When you have an error please at least read it and make an attempt to comprehend what it is saying. –  tgm4883 Jul 11 '13 at 15:37

Not the answer you're looking for? Browse other questions tagged or ask your own question.