Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an HP DM4 laptop running Ubuntu 13.04 (although i've noticed this on 12.04 and 12.10). When I am connected to the WiFi at home none of my housemates are able to get decent connection. They can connect but not use the internet. I've noticed it a number of other places including hotspots in motels etc.

It's not a problem for me but I am becoming increasingly unpopular at home!!

I have the Broadcom STA Wireless driver installed and am using it.

Let me know if I can give any more useful information.

Thanks

share|improve this question
    
This could be a driver issue. Someone has the same issue with the same laptop here: Laptop blocking other computers on home WiFi routers. From the comments there, someone managed to fix it by using another wireless driver (ubuntuforums.org/showthread.php?t=2131244). Also, it's worth checking the answer here first: Ubuntu 13.04 causes other pcs internet to be slow?. Disable the proprietary driver by going to the "Software & Updates" application, and go to the last tab "Additional Drivers". –  Alaa Ali Jul 11 '13 at 10:19
    
Which one? Which steps did you follow? –  Alaa Ali Jul 11 '13 at 23:25
    
I followed the steps in this thread (ubuntuforums.org/showthread.php?t=2131244) blacklisting the various broadcom drivers and enabling the correct kernel module. –  faithinfriction Jul 12 '13 at 5:06
1  
Since the steps in the thread are not documented here on AskUbuntu, and the person that asked the other question hasn't visited for quite some time, I'll answer your question, and you can mark it as accepted to indicate to others that it has been solved. –  Alaa Ali Jul 12 '13 at 11:05

2 Answers 2

up vote 1 down vote accepted

From here: http://ubuntuforums.org/showthread.php?t=2131244

  1. Open up the file /etc/modprobe.d/blacklist.conf with your favorite text editor, and add the following to the end of the file:

    blacklist bcm43xxblacklist b43
    blacklist b43legacy
    blacklist bcma
    blacklist ndiswrapper
    blacklist wl
    
  2. Open up the file /etc/modules with your favorite text editor, and add the following at the end of the file:

    brcmsmac
    

    Alternatively, you can type sudo sh -c "echo 'brcmsmac' >> /etc/modules" in a terminal to do this in one go.

  3. Reboot the machine.

share|improve this answer

This has happened to me a few times.

It usually is a problem with the router, not your wi-fi.

  1. Unplug the router from the power outlet and wait 20seconds before plugging in again.
  2. Reboot your PC also just to be sure.

Another problem can be an IP conflict

So you have to reserve a dedicated internal IP address for your computer.

  1. Access your router using the internal IP (usually 192.168.0.1 if using a DLink device but it may vary)
  2. Use your user and password (usually user:"admin" and pasword:"admin" or blank)
  3. Search for "Network settings" and wherever you notice a table of MACaddresses and IP numbers, you should find a button to "reserve" IPs.
  4. Reserve the IPs of devices you recognize as yours and your roomates (so each one has it's own IP and there should be no conflict).

NOTE: Instrucctions are different depending on the make and model of your router.

And that's that.

share|improve this answer
    
+1 crappy router. –  fleamour Jul 12 '13 at 11:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.