Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu from the previous long time almost 2 years. Today there is need to type a letter in the Punjabi language[named as Lohit Punjabi] in Libre office. But when I was being try to write in specimen language it just be write in English! I had searched that problem from Google search but don't get sufficient answer. So any one can give me some couples of suggestion & feedback regards how I can add the language[punjabi] in Libre office. Thanks on the behalf of your worthily suggestion.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

First you have to add the Punjabi language to the list of keyboard layout languages, so that you can switch back and forth between your system's default language and Punjabi by clicking on the language switcher icon in the system notification area next to the system clock. Click System Settings (in the Launcher) -> Keyboard Layout and you will see the Keyboard Layout window shown below:

enter image description here

Click on the + button in the lower left-hand corner of the Keyboard Layout window to open the Choose a Layout window shown below:

enter image description here

Select your new keyboard layout language from the list and click Add to add Punjabi to your keyboard layout languages.

The part of your question about how to add Punjabi language features to LibreOffice is answered in great detail in the illustrated document LibreOffice Getting Started Guide. This document contains a complete description of everything you need to do to add a language to LibreOffice on page 55, including how to:

  • Install the required dictionaries
  • Change some locale and language settings
  • Choose spelling options
share|improve this answer
    
@Karel.. thank you for your article. Its works. This is to be so simply & well described format Its take just one minute to resolve my problem. So Thanks again. –  Hdhams Jul 13 '13 at 17:14
    
Ok.. I click the gray check mark as you suggested ..with this acceptance that this is a well answered of my question or my problem is to be solved out now. –  Hdhams Aug 7 '13 at 9:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.