Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to downgrade mysql from 5.1 to 5.0.

After running apt-get remove mysql-server-5.1 I am attempting to run apt-get install mysql-server-5.0.

It says: Note, selecting 'mysql-server-5.1' instead of 'mysql-server-5.0'

How do I force it not to do that and to use 5.0 as desired?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

MySQL 5.0 is not available for anything after Ubuntu 8.04 (hardy). 8.04 Server Edition is still supported for a couple of years, so that might be an option for you.

Here are the official packages by release for 5.0:

$ rmadison mysql-server-5.0
mysql-server-5.0 | 5.0.21-3ubuntu1 |        dapper | amd64, i386, powerpc
mysql-server-5.0 | 5.0.22-0ubuntu6.06.15 | dapper-security | amd64, i386, powerpc
mysql-server-5.0 | 5.0.22-0ubuntu6.06.15 | dapper-updates | amd64, i386, powerpc
mysql-server-5.0 | 5.0.51a-3ubuntu5 |         hardy | amd64, i386
mysql-server-5.0 | 5.0.51a-3ubuntu5.8 | hardy-security | amd64, i386
mysql-server-5.0 | 5.0.51a-3ubuntu5.8 | hardy-updates | amd64, i386
mysql-server-5.0 | 5.1.30really5.0.83-0ubuntu3 | karmic/universe | amd64, i386
share|improve this answer
    
I'm developing on Ubuntu 10.10, but the live server which the development environment needs to mirror to eliminate problems is running on MySQL 5.0.x. I can't change either OS. –  bcmcfc Mar 24 '11 at 17:38
    
I would suggest creating a virtual machine that mirrors the production environment. You could also start up an instance of Ubuntu 8.04 on Amazon EC2 for your development. –  Mark Russell Mar 24 '11 at 18:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.