Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am on Ubuntu 13.04 64-bit. I have heard that setting the cpufreq governor to performance will, well, increase performance. Unfortunately, I am a bit of a newbie at this sort of thing, and I am not sure how I would go about doing this. If I do sudo cpufreq-set -c 0 -g performance I get:

Error setting new values. Common errors:
- Do you have proper administration rights? (super-user?)
- Is the governor you requested available and modprobed?
- Trying to set an invalid policy?
- Trying to set a specific frequency, but userspace governor is not available,
   for example because of hardware which cannot be set to a specific frequency
   or because the userspace governor isn't loaded?

cpufreq-info gives me:

cpufrequtils 008: cpufreq-info (C) Dominik Brodowski 2004-2009
Report errors and bugs to cpufreq@vger.kernel.org, please.
analyzing CPU 0:
  no or unknown cpufreq driver is active on this CPU
  maximum transition latency: 4294.55 ms.
analyzing CPU 1:
  no or unknown cpufreq driver is active on this CPU
  maximum transition latency: 4294.55 ms.

This is the output of cat /proc/cpuinfo

processor   : 0
vendor_id   : GenuineIntel
cpu family  : 15
model       : 4
model name  : Intel(R) Pentium(R) D CPU 2.80GHz
stepping    : 4
microcode   : 0x6
cpu MHz     : 2800.026
cache size  : 1024 KB
physical id : 0
siblings    : 2
core id     : 0
cpu cores   : 2
apicid      : 0
initial apicid  : 0
fpu     : yes
fpu_exception   : yes
cpuid level : 5
wp      : yes
flags       : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc pebs bts nopl pni dtes64 monitor ds_cpl cid cx16 xtpr
bogomips    : 5600.05
clflush size    : 64
cache_alignment : 128
address sizes   : 36 bits physical, 48 bits virtual
power management:

processor   : 1
vendor_id   : GenuineIntel
cpu family  : 15
model       : 4
model name  : Intel(R) Pentium(R) D CPU 2.80GHz
stepping    : 4
microcode   : 0x6
cpu MHz     : 2800.026
cache size  : 1024 KB
physical id : 0
siblings    : 2
core id     : 1
cpu cores   : 2
apicid      : 1
initial apicid  : 1
fpu     : yes
fpu_exception   : yes
cpuid level : 5
wp      : yes
flags       : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc pebs bts nopl pni dtes64 monitor ds_cpl cid cx16 xtpr
bogomips    : 5600.05
clflush size    : 64
cache_alignment : 128
address sizes   : 36 bits physical, 48 bits virtual
power management:

any help would be appreciated.

share|improve this question
    
Report errors and bugs to cpufreq@vger.kernel.org, please. –  Radu Rădeanu Aug 19 '13 at 20:17

2 Answers 2

My suspicion is that P4 hardware does not support the type of CPU scaling that you are trying to set. In essence, your P4 cpu is already running full speed.

You can use the command cpufreq-info to get information about what your hardware is capable of. It will tell you the valid settings you can use. On a P4 system, I get this:

cpufrequtils 007: cpufreq-info (C) Dominik Brodowski 2004-2009
Report errors and bugs to cpufreq@vger.kernel.org, please.
analyzing CPU 0:
  no or unknown cpufreq driver is active on this CPU
  maximum transition latency: 0.00 ms.
analyzing CPU 1:
  no or unknown cpufreq driver is active on this CPU
  maximum transition latency: 0.00 ms.

On a newer Core2Duo system I get this:

cpufrequtils 007: cpufreq-info (C) Dominik Brodowski 2004-2009
Report errors and bugs to cpufreq@vger.kernel.org, please.
analyzing CPU 0:
  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 10.0 us.
  hardware limits: 1000 MHz - 2.17 GHz
  available frequency steps: 2.17 GHz, 2.00 GHz, 1.83 GHz, 1.67 GHz, 1.50 GHz, 1.33 GHz, 1000 MHz
  available cpufreq governors: conservative, ondemand, userspace, powersave, performance
  current policy: frequency should be within 1000 MHz and 2.17 GHz.
                  The governor "ondemand" may decide which speed to use
                  within this range.
  current CPU frequency is 1000 MHz.
  cpufreq stats: 2.17 GHz:4.03%, 2.00 GHz:0.01%, 1.83 GHz:0.01%, 1.67 GHz:0.01%, 1.50 GHz:0.01%, 1.33 GHz:5.14%, 1000 MHz:90.80%  (28070386)
analyzing CPU 1:
  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 1
  CPUs which need to have their frequency coordinated by software: 1
  maximum transition latency: 10.0 us.
  hardware limits: 1000 MHz - 2.17 GHz
  available frequency steps: 2.17 GHz, 2.00 GHz, 1.83 GHz, 1.67 GHz, 1.50 GHz, 1.33 GHz, 1000 MHz
  available cpufreq governors: conservative, ondemand, userspace, powersave, performance
  current policy: frequency should be within 1000 MHz and 2.17 GHz.
                  The governor "ondemand" may decide which speed to use
                  within this range.
  current CPU frequency is 1000 MHz.
  cpufreq stats: 2.17 GHz:2.88%, 2.00 GHz:0.00%, 1.83 GHz:0.00%, 1.67 GHz:0.01%, 1.50 GHz:0.01%, 1.33 GHz:1.87%, 1000 MHz:95.23%  (3085131)
share|improve this answer

There may be BIOS settings that are disabling CPU frequency scaling... I don't know about a P4 specifically, but I do know that on some AMD's they can be set to max frequency with no scaling (maybe disabling Cool'n'quiet or similar in BIOS?)

Also some laptops may disable frequency scaling and run only at the lowest cpu speed IF there's no battery installed (Thinkpad), reasoning that the AC adapter can't supply enough power for full frequency...

Something to check before giving up on freq scaling, especially if your CPU manufacturer says it's supported.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.